Remote calling - not available

hello

I am trying to call from remote soft phone to another extension on local network.
While i can make call from local extension to remote softphone, other way round is not possible.
Also i am not able to dial external numbers from remote softphone.

Attached sngrep logs and asterisk logs

pastebin

Any solution??

also in the logs i have noticed there is a private IP address - 10.81.206.133 which comes up multiple times and is not in my network subnet, i dont know why this is there.

No href= in your link anchor!

added

You are trying to set up encrypted media, but sending the encryption keys over an open (UDP) channel. Whilst I’m surprised Asterisk allows you to try, the endpoint is simply stopping your making a big mistake.

Maybe the endpoint is registering with SIP: contact addresses?

Hello
I am quite noob with the terminology,
But the same settings works on same softphone when on local network (wifi/ethernet).
What i have concluded as per sngrep logs is
the call made from remote extension ([email protected]) to local extension ([email protected]_IP) is not getting resolved.
it should have been [email protected] ----> [email protected]_IP
but it is coming as [email protected] ----> [email protected]

Where
remoteIP=public ip address / DDNS_domain
local_IP=internal network IPof the client(192.168.1.99)

2023/01/24 21:43:07.045831 PUBLIC_IP:8496 -> 192.168.1.81:5160
INVITE sip:[email protected]_DOMAIN:5160 SIP/2.0
Via: SIP/2.0/UDP 10.81.206.133:5160;branch=z9hG4bK1322627670;rport
From: "puneet" <sip:[email protected]_DOMAIN:5160>;tag=1099963502
To: <sip:[email protected]_DOMAIN:5160>

i may be wrong

I got the direction of the call wrong above, and have corrected it.

Now that you point out the local address, I think we can safely say you have SIP ALG (application level gateway) in the router. This should be disabled, as, as in this case, it is typically badly implemented.

Hello

I am using Pfsense and as per the documentations and forum data, there is no SIP ALG on pfsense.

Also i am able to make calls to the remote extension from any extension on the local network.

Netgate official forum thread

Sorry, I wasn’t thinking straight. You should see the internal destination address. The only problem is that you are getting not acceptable here for SDP, and that is pretty obviously because you are trying to invoke SRTP in an unsafe way. Even if Asterisk allows this, you should not do it.

You will need symmetric RTP enabling. I can’t remember what the default is. That is because the phone is failing to compensate for being behind NAT. You might want to look into whether the phone supports STUN.

Hello
its working now

yes so you were correct, the SRTP enabled was the issue.
BTW i am using GS wave lite softphone.
in the account settings towards the end of the menu there are two sub menu for SRTP

  1. SRTP mode - i have now set it to disabled
  2. Enable SRTP key life time - i have unchecked it now
  3. in the pfsense i have made ports static in the outbound NAT
    official netgate guide for others also

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.