Remote Agents in Queue & skip busy

I have 2 FreePBX installations connected over an IAX2 trunk. Call it System A & System B.
I have queues on both systems.
In my one queue on System A I need to add remote agents from System B.

If I add them as static agents by just typing their extension number and penalty value they are added to the queue and will get calls. When they pause themselves in the queue that appears to work as well.

What doesn’t work is the “skip busy agents”. I’ve tried setting skip busy agents to Queue calls only and Yes+(ringinuse=no) with Agent Restrictions set to Extensions Only. In all cases it doesn’t prevent calls into the queue from ringing the remote extension. Doesn’t matter if it is an outbound call they initiated or an inbound call to a different queue (like one of the queues local to their PBX).

I suspect the only way this would work is if the remote PBX (System B) could see device hints related to “status” over the IAX2 trunk. Not sure if it does that.

Also I can see when adding the extension to the remote queue it adds as if it’s a “local” extension.

1097 has 0 calls (max unlimited) in 'ringall' strategy (5s holdtime, 72s talktime), W:0, C:4, A:8, SL:100.0% within 120s
      Local/2007#@from-queue/n (ringinuse disabled) (Not in use) has taken no calls yet

Not seeing that states is exactly the problem. If IAX can allow that, I am not sure. I know you can via SIP.

Is there some special way to add a remote extension to a queue that tells it “hey, this is actually over here on this other server @ this IP/Hostname”?

Nope. You have to have the states local. So you would have to send them across.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.