Reload failed because retrieve_conf encountered an error: 255


(Rjm) #1

While using the upgrade tool Elastix and PBXinaFlash to FreePBX Distro Conversion Tool

I get the following error when hitting the Apply Config button after the tool has sent the configs over to the new system:

exit: 255
Unable to continue. Inbound Route / does not have a valid destination in /var/www/html/admin/modules/core/functions.inc.php on line 1410
#0 /var/www/html/admin/libraries/BMO/DialplanHooks.class.php(95): core_do_get_config(‘asterisk’)
#1 /var/lib/asterisk/bin/retrieve_conf(864): FreePBX\DialplanHooks->processHooks(‘asterisk’, Array)
#2 {main}

Dashboard shows Reload failed because retrieve_conf encountered an error: 255

The donor system is FreePBX 12.0.76.6 and the new host is FreePBX 13.0.197.22

Would one of you more knowledgeable folks please point me in the right direction? Am I missing something?

Thanks


(Lorne Gaetz) #2

Error says it all. Check all your inbound routes, one or more has a bad dest.


(Rjm) #3

Thanks Lorne. I had tried that in a prior build, but I think I got googled off the right path and tried that last. I’ll take another look doing route triage first. Thank you.

Edit: There was one default route in there with no destination. It was the ANY route which was not pointed anywhere. Killed it off and reapplied with success! Thanks again!


(Rjm) #4

One other question, if I may. I am doing this move to allow pjsip connections with flowroute, as the Nevada POP is going dark on June 11, 2020. The other edge servers don’t allow sip/chan_sip so I need to connect some other way. I was thinking pjsip.

As the pjsip trunk tab was not available, I started looking into why. I noticed that the FreePBX V12 machine could be set to BOTH for a SIP driver.

So my question is, if I change

SIP channel driver from “chan_sip” to “both”, leave the extensions on chan_sip, and set up trunks for pjsip, will this work? In other words, will chan_sip talk with pjsip?


(Itzik) #5

The Trunk and extensions do not have to use the same technology.


(Rjm) #6

Thank you!


(Dave Burgess) #7

… and will not use the same UDP port.


(system) closed #8

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.