Reload failed because retrieve_conf encountered an error: 255

Hello,

Im getting the error:

Reload failed because retrieve_conf encountered an error: 255

On the main dashboard.

If I run fwconsole r --verbose via ssh I get:

Error(s) have occured, the following is the retrieve_conf output: exit: 255
Unable to continue. Call to undefined function FreePBX\modules\endpoint_apiApp() in /var/www/html/admin/modules/restapps/Restapps.class.php on line 1314
#0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(383): Whoops\Run->handleError(1, 'Call to undefin...', '/var/www/html/a...', 1314)
#1 [internal function]: Whoops\Run->handleShutdown()
#2 {main}

Any help to get past this error would be appreciated!

Thanks

What is the result of:

fwconsole ma list | grep endpoint
| endpoint   | 14.0.2.48  | Disabled; Pending upgrade to 14.0.2.59 | Commercial |

Looking at the update section, it says I’m up to date but I’m on 14.0.2.18


EPM is disabled for some reason:

fwconsole ma install endpoint

How long should the command take? Its been sitting on “Checking Settings and Defaults” for about 15 min

[[email protected] ~]# fwconsole ma install endpoint
Checking database tables...Done
Migrating tables as required...Done
Checking Settings and Defaults...

Did it install at the end?..

Yes, the install ended, it took about 45 minutes to install.

Now the dashboard is saying:

The following modules are disabled because they need to be upgraded:
pms

You should go to the module admin page to fix these.

And if I go to the module upgrade page nothing is listed as needing to be updated.

[[email protected] ~]# fwconsole r --verbose
Reloading FreePBX
        exit: 0
        Unknown Error. Please Run /var/lib/asterisk/bin/retrieve_conf
Successfully reloaded
[[email protected] ~]# /var/lib/asterisk/bin/retrieve_conf
Please update your modules and reload Asterisk by browsing to your server.

fwconsole ma list | grep pms
If it says disabled, just run
fwconsole ma enable pms

Or… try refreshing your dashboard

I ran

fwconsole ma install pms

and it took care of the issue. Thanks for the help!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.