Reload failed because retrieve_conf encountered an error: 255

Hi. I’ve updated FreePBX modules. After update Apply config isn’t working. Error:

exit: 255
Unable to continue. Cron line added didn’t remain in crontab on final check in /var/www/html/admin/libraries/BMO/Cron.class.php on line 113
#0 /var/www/html/admin/libraries/BMO/Cron.class.php(180): FreePBX\Cron->addLine(‘59 23 * * 0 /va…’)
#1 /var/www/html/admin/libraries/utility.functions.php(624): FreePBX\Cron->add(‘59 23 * * 0 /va…’)
#2 /var/www/html/admin/modules/queues/ edit_crontab(’’, Array)
#3 /var/www/html/admin/modules/queues/ queues_set_backup_cron()
#4 /var/www/html/admin/libraries/BMO/DialplanHooks.class.php(95): queues_get_config(‘asterisk’)
#5 /var/lib/asterisk/bin/retrieve_conf(866): FreePBX\DialplanHooks->processHooks(‘asterisk’, Array)
#6 {main}

I found similar topics here, did what said experts on these topics, but problem is still remaining. Please, help me.

You need to install cron tab

I’ve installed crontabs, cronie, cronie-anacron. Not solved. Is there another cron package?

Versions are: CentOS 7.3, FreePBX, Asterisk 13.12.2.

Freepbx 13 isn’t supported on centos 7.

What? The “recommended” distribution for FreePBX 13 is CentOS 7. Look at here. (

I’ve solved the problem. Problem was with syntax problem in asterisk cron file /var/spool/cron/asterisk . I renamed cron file asterisk, then fwconsole reload , fwconsole restart. This procedure created new asterisk cron file. Then everything worked !!!