Reload failed because retrieve_conf encountered an error: 126


This is also considered hijacking a thread (just like the poster above your post). Please post a new thread with a proper subject and I’ll bet you’ll get answers. Here at the end of the thread about a retrieve_conf error you will not.

I had this problem after a fresh install of Trixbox 2.2.12 (the last one that still runs on C3 processors) and then did an update to FreePBX versions 2.4 then 2.5.

All seemed to work correctly until my fellow admin changed something on the “General Settings” page and got the error that started the thread.

I did this and it seemed to fix things:

cd /var/lib/asterisk/bin

chmod a+x *

I’m concerned there may be similar problems lurking elsewhere, but the phones are ringing again, so on to the next problem!

cheers, michael

It seems it’s gone after I added a new extension and saved.

I have same problem, but other error


Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf …OK
Bootstrapping /etc/amportal.conf …OK
Parsing /etc/amportal.conf …OK
Parsing /etc/asterisk/asterisk.conf …OK
Connecting to database…OK
PHP Warning: Missing argument 1 for connectdirs::create(), called in /var/lib/asterisk/bin/retrieve_conf on line 430 and defined in /var/lib/asterisk/bin/retrieve_conf on line 13
Connecting to Asterisk manager interface…OK
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = ****
Added to globals: AMPDBENGINE = mysql
Added to globals: AMPDBHOST = localhost
Added to globals: AMPDBNAME = asterisk
Added to globals: AMPDBUSER = asteriskuser
Added to globals: AMPDBPASS = ****
Notice: no Queues defined
Notice: no Parking Lots defined
Notice: no iax trunks defined
Notice: no AMP Users defined
Please update your modules and reload Asterisk by visiting

In /var/lib/asterisk/bin/retrieve_conf i have “function &create(&$db) {” at line 13 and “$con_dirs = connectdirs::create();” at line 430. FreePBX
Any idea here?

it’s a harmless warning that has been fixed and will be out in the next framework update.

Is it making your system fail though? If so, you may need to turn down your error reporting in php to keep it from failing your reload until the fix is pushed out (or just go modify the code until then and get rid of the &$db in the declaration which was a bug and has been removed)>

I’ve encountered same problem in FreePBX(meanwhile asterisk was working without an issue).
Solutions posted here was not helpful so I thought posting here the one that resolved my problem could save some time. I found it on Elastix forum:

change selinux from to permissive either by running “setup” from console or by editing /etc/selinux/config file

selinux should be diabled!!!

disable SELinux, it works for me