FreePBX | Register | Issues | Wiki | Portal | Support

Reload failed because retrieve_conf encountered an error: 1

configuration
Tags: #<Tag:0x00007fd2e4d12950>

(FAK) #1

hi guys,

I am getting below error whenever I click on the apply config button on the gui however when I run command fwconsole reload this error removed.

this is the error in the pop up message

exit: 1
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
Exception: Unable to connect to Asterisk through the CLI in file /var/lib/asterisk/bin/retrieve_conf on line 41
Stack trace:

  1. Exception->() /var/lib/asterisk/bin/retrieve_conf:41


(FAK) #2

can anyone help me on this.


(Dave Burgess) #3

Asterisk has gone away. Try fwconsole restart instead and let us know what the error is.


#4

Very often Asterisk has not “gone away” and is running perfectly fine, but not as user:asterisk group:asterisk and then the GUI can’t see it. If the Freepbx is distro based that is not likely to happen, if homebrewed, you will have to fix your init script to not use root.or only tely on fwconcole/amportal start/stop wrappers


(FAK) #5

yeah it’s not a distro but I figured it out by doing some restarts to asterisk and fwconsole restart.

now it works.


#6

You need to fix the base problem, how did you install Asterisk and on what OS


(FAK) #7

I install it manually from Freepbx installation guide.
I install this on AWS.

Is there anyway that we can install distro on AWS?


#8

You did didn’t state the OS of your AWS nor the FreePBX installation guide you followed.


(FAK) #9

OS is centos 6.5 and asterisk 13


(FAK) #10

https://wiki.freepbx.org/display/FOP/Installing+FreePBX+13+on+CentOS+6

this is the guide.


(FAK) #11

2.6.32-696.13.2.el6.x86_64