Reload failed because retrieve_conf encountered an error: 1

Hi guys before hand i want to thank you for your help, i am new at this so i don’t have much experience. i just recently started an internship and i was asked to download freepbx 13 and restore a backup from a previous version. Now i have 7 errors in my dashboard, and every time i hit apply config the following error comes up. I have done a lot of research online but i haven’t been able to figure out how to solve it. Please any help is appreciated, just go easy on me.

Reload failed because retrieve_conf encountered an error: 1
exit: 1
Exception: Unable to locate the FreePBX BMO Class 'Media’A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install media 2) fwconsole ma enable media in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 216
Stack trace:

  1. Exception->() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:216
  2. FreePBX\Self_Helper->loadObject() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:104
  3. FreePBX\Self_Helper->autoLoad() /var/www/html/admin/libraries/BMO/Self_Helper.class.php:37
  4. FreePBX\Self_Helper->__get() /var/lib/asterisk/bin/retrieve_conf:57

i ran the following commands as instructed -
fwconsole ma install media 2, fwconsole ma enable media in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 216

then i got this -
[[email protected] ~]# fwconsole ma install media 2
Unable to install module media:

  • Cannot find module
    Unable to install module 2:
  • Cannot find module
    Updating Hooks…Done
    [[email protected] ~]# fwconsole ma enable media in file /var/www/html/admin/libraries/BMO/Self_Helper.class.php on line 216
    The following error(s) occured:
  • Module media cannot be enabled

i also ran fwconsole debug:

[[email protected] ~]# fwconsole debug
±----------------------+
| FreePBX Notifications |
±----------------------+

A network interface that is assigned to the ‘Trusted’ zone has been detected. Th is is a misconfiguration. To ensure your system is protected from attacks, pleas e change the default zone of interface ‘eth0’.

Reload failed because retrieve_conf encountered an error: 1
The following commands failed with the listed error
/var/lib/asterisk/bin/module_admin listonline (1)
Please run 'touch ’ and then ‘fwconsole chown’ to create this file.
retrieve_conf failed to sym link:
   /etc/asterisk/logger.conf from core/etc (Already exists, not a link)<br >This can result in FATAL failures to your PBX. If the target file ex ists and not identical, the symlink will not occur and you should rename the tar get file to allow the automatic sym link to occur and remove this error, unless this is an intentional customization.
The system detected a problem trying to access external server data and changed internal setting MODULEADMINWGET (Use wget For Module Admin) to true, see the to oltip in Advanced Settings for more details.
The following new modules are available for download. Click delete icon on the r ight to remove this notice.

THANK YOU

Was the backup you restored from made on a 13 system?

No the backup was made on the previous version of freepbx.

Problem identified. Your new install is not recoverable. Start with a new install using the same version of FreePBX that the backup was made from.

If the old system is still up and running, you can use this script to migrate settings:
http://wiki.freepbx.org/display/PPS/Elastix+and+PBXinaFlash+to+FreePBX+Distro+Conversion+Tool

WOW aight thank you so much i’ll do that.

Good morning i hope you all had a great weekend.

Igaetz when i got to work today i went to that link and i followed the instructions, my new freepbx was registered successfully and i ran the script and got the slot identifier number so everything was fine. But when i ran the script in my old freepbx (version 2-10) it does nothing, it does not ask me for the slot identifier number. do you have any other tips on what else’s can i do?