Reload does not reload

I’ve upgraded from Trixbox to PBXinaFlash and I have the following problem.
Every time I make a change to the dial plan, extensions, outbound routes, etc, and I click on the “Apply configuration changes” and reload, the system seems like it’s reloading (I can see this via a ssh window) but changes are not applied.
If I issue the reload command via CLI, it also shows like it’s reloading, but changes are not applied

I’ve tried everything I could think of, but, simply, Reload does not reload.

Any expert who could help me?

Thanks,
HernanP

run /var/lib/asterisk/bin/retrieve_conf from the Linux command line, as user asterisk and see what it tells you.

Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Checking for /etc/amportal.conf …OK
Bootstrapping /etc/amportal.conf …OK
Parsing /etc/amportal.conf …OK
Parsing /etc/asterisk/asterisk.conf …OK
Connecting to database…OK
Connecting to Asterisk manager interface…OK
Sun, 30 Dec 2007 11:52:28 -0600 - Got event… registry
Sun, 30 Dec 2007 11:52:28 -0600 - No event handler for event 'registry’
Added to globals: ASTETCDIR = /etc/asterisk
Added to globals: ASTMODDIR = /usr/lib/asterisk/modules
Added to globals: ASTVARLIBDIR = /var/lib/asterisk
Added to globals: ASTAGIDIR = /var/lib/asterisk/agi-bin
Added to globals: ASTSPOOLDIR = /var/spool/asterisk
Added to globals: ASTRUNDIR = /var/run/asterisk
Added to globals: ASTLOGDIR = /var/log/asterisk
Added to globals: CWINUSEBUSY = true
Added to globals: AMPMGRUSER = admin
Added to globals: AMPMGRPASS = amp111
Please update your modules and reload Asterisk by browsing to your server.
[email protected]:~ $

Any clue?
Thanks!

according to that output, your auto generated conf files should have been updated with the new settings - there were no errors reported to the contrary.

That’s correct, no errors there, but my dial plan does not change if I change a route and reload the configuration.

I’ve deleted a route, reloaded and the call still uses the non-existent route. Same with Extensions-custom.conf, made a custom extension and does not get loaded.

That’s why I posted the issue.

Shall I reinstall everything from scratch?

I ran that command as root.

How do I log in as user asterisk? I don;t have a password for that user…

Would that show any different output?

Thanks
Hernan

It’s working now. I have changed extensions.conf to include extensions_custom.conf and something is not right there.

I’ll keep trying to make extensions_custom.conf work, but this post can be closed as it reloads OK now.

Thanks!