Registering against Sipgate suddenly failing - 'request sent'

Logs above, anyone idea what’s going wrong?

SIP ALG is turned off in my router.

All of my setting USED to work but just suddenly stopped a while back.

I’d love to get it sorted out.

Many thanks

A common cause of this symptom is a ‘poisoned’ NAT association being kept alive by aggressive retries.

You can probably clear it by disabling the trunk (or shutting down the whole PBX) for at least 10 minutes. Or, with the server shut down, reboot modem and router. After they have come back up, restart the PBX.

Another possibility is that your IP address changed; check that in Asterisk SIP Settings, External Address and Local Networks are correctly set. A change requires an Asterisk restart.

If you still have trouble, at the Asterisk command prompt type
sip set debug on
wait for a registration attempt, then paste a new log.

When you paste, please leave the Paste Expiration setting at the default of ‘Never’, so that future readers of the thread can follow along.

BTW, now may be a good time to switch the trunk to pjsip (which would avoid any old NAT associations).

Thanks Stewart, I took your advice, switched to PJSIP and it instantly worked. How weird! Is PJSIP less susceptible to this poisoning than SIP is? I’ve never come across anything like this.
Thank you

Unfortunately, not. Switching worked because the bad association was on a different port.

If you must work around the problem, set the retry and qualify timeouts to be longer than the UDP timeout in the router.

Possibly, there is newer firmware available for your router that fixes the trouble.

Or, if your budget permits, replace the old turkey with something more robust. In general, anything ‘prosumer’ or better will not have the issue (Mikrotik, Ubiquiti, business products from TP-Link or Netgear, Cisco Small Business, etc.)

A weird error has cropped up. Since changing the Sipgate trunk to PJSIP from SIP, it seems the DID is not being passed anymore.

I found an old @lgaetz tip to set the trunk context to from-pstn-toheader but sadly it seems Sipgate are passing my USERNAME as the DID instead of the actual DID.

Any ideas? This wasn’t a problem when I was using SIP.


post a log, is your did in any header ?

Put your DID in Contact User and change Context back to default.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.