Register Polycom RMX MCU with Freepbx


(Greg) #1

Hello all.
Did anyone tried to register Polycom MCU with FreePBX ? Always getting authentication failure, extension created, user as well. Not progressing at all…


#2

Some devices can’t handle the long password autogenerated by FreePBX. Create a password consisting of no more than 12 letters and digits. Put it into both Secret for the extension and the SIP password for the device.

Also, confirm that the port to which the device is connecting matches the channel driver you are using. If you created a pjsip extension, the Poly should connect to whatever Port to Listen On is set to (default 5060). For chan_sip, whatever Bind Port is set to (default 5160).

If you still have trouble, post the Asterisk log for an attempted registration.


(Greg) #3

From: “RMX_192.168.1.200” sip:RMX_192.168.1.200@vc.intersnack.com;tag=rmx2k_4068817485-3099;epid=0x120e15ac
2256992 To: “RMX_192.168.1.200” sip:RMX_192.168.1.200@real_domain_removed
2256993 Contact: sip:RMX_192.168.1.200@192.168.1.200:5060;transport=tcp;isfocus
2256994 Authorization: Digest username=“RMX_192.168.1.200”,realm=“asterisk”,nonce=“1622032827/7de1d332add34189a953b8f3242967f1”,uri=“sip:real_domain_removed”,response=“64a7769baadf4fdd0dcc7b21eadaef56”,algorithm=md5,cnonce=“021019606492-PLCM”,opaque=“0e0e963572f25487”,qop=auth,nc=00000001
2256995 [2021-05-26 12:40:27] NOTICE[1781] res_pjsip/pjsip_distributor.c: Request ‘REGISTER’ from ‘“RMX_192.168.1.200” sip:RMX_192.168.1.200@real_domain_removed’ failed for ‘192.168.1.200:60000’ (callid: 4068817432-3099-RMX-00000000) - Failed to authenticate
2256996 [2021-05-26 12:40:27] VERBOSE[1781] res_pjsip_logger.c: <— Transmitting SIP response (586 bytes) to TCP:192.168.1.200:60000 —>
2256997 Via: SIP/2.0/TCP 192.168.1.200:5060;rport=60000;received=192.168.1.200;branch=z9hG4bK4068842663-3099
2256998 From: “RMX_192.168.1.200” sip:RMX_192.168.1.200@real_domain_removed;tag=rmx2k_4068817485-3099;epid=0x120e15ac
2256999 To: “RMX_192.168.1.200” sip:RMX_192.168.1.200@real_domain_removed;tag=z9hG4bK4068842663-3099


#4

Can you try a simple numeric extension number e.g. 101, instead of RMX_xxxxxx?

If you still have trouble, paste the log at pastebin.freepbx.org and post the link. The log you posted got garbled by the forum.


(Ricardo) #5

Hi, how about try to add username into server address setting.
user_name@server_address