Receptionist queue has failed

Our main company phone number goes to a ringall queue with 2 static agents (the receptionists).
Everything was working perfectly until around a week ago.
The problem now is that if one of the receptionists is already on a call when another call comes in from outside, the other receptionist gets a strangled half ring from their phone and the caller hears “The number you just dialled is busy or unavailable at this time” - our standard no answer / busy / unreachable IVR.
I’ve tried creating a new queue - same result.
Other queues seem to be fine.

We are using Asterisk version 16.28.0, FreePBX version 16.0.21.18, queues version 16.0.18

Sounds like there’s another logged in agent for the queue that’s an invalid dial string. A call trace will show what’s going on, but you can see queue agents from the Asterisk CLI with

queue show
queue show <queue_number>

Is the second receptionist phone forwarded to an invalid destination?

I get
No such command ‘queue’

Both are valid extensions

OK figured the queue command:

freepbx*CLI> queue show 500
500 has 0 calls (max unlimited) in ‘ringall’ strategy (1s holdtime, 10s talktime), W:0, C:464, A:22, SL:100.0%, SL2:98.8% within 60s
Members:
Clare Robinson (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (Busy) has taken 350 calls (last was 12075 secs ago) (login was 35 secs ago)
Reception (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (Busy) has taken 373 calls (last was 10559 secs ago) (login was 35 secs ago)
No Callers

Both phones are on DND because reception is closed on Friday afternoons

Now that the queue is in regular service (not out of hours) I get this:

freepbx*CLI> queue show 500
500 has 0 calls (max unlimited) in ‘ringall’ strategy (1s holdtime, 12s talktime), W:0, C:465, A:22, SL:100.0%, SL2:98.8% within 60s
Members:
Clare Robinson (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (Not in use) has taken 355 calls (last was 4 secs ago) (login was 251316 secs ago)
Reception (Local/[email protected]/n from hint:[email protected]) (ringinuse enabled) (Not in use) has taken 417 calls (last was 145 secs ago) (login was 251316 secs ago)
No Callers

We can still only get 1 incoming call at a time though

Can you share your queue settings?

Skip Busy Agents = Yes
The agent ring time seems a little quick to me, but if that has been working for you, should be okay.

As far as I’m aware, most, if not all of the settings are the default.
But I’m willing to try changing anything - we can’t keep losing calls

Did the Skip Busy Agents = Yes change work?

Sorry - I didn’t realise that was a suggestion.
I’ll try it now