Receivefax stopped working

Using the latest Freepbx w/sipstation my faxes stopped working. Only thing I can think of that I did was “asterisk-version-switch” to asterisk 13. I notice the log says “No application ‘ReceiveFAX’ for extension (ext-fax, s, 4)”. core show applications does not show receivefax. Log…

   -- Executing [[email protected]:1] NoOp("SIP/fpbx-2-zIetkx3ctJ74-00000093", "Starting recording check against dontcare") in new stack
-- Executing [[email protected]:2] Goto("SIP/fpbx-2-zIetkx3ctJ74-00000093", "dontcare") in new stack
-- Goto (sub-record-check,recordcheck,3)
-- Executing [[email protected]:3] Return("SIP/fpbx-2-zIetkx3ctJ74-00000093", "") in new stack
-- Executing [[email protected]:5] Return("SIP/fpbx-2-zIetkx3ctJ74-00000093", "") in new stack
-- Executing [[email protected]:3] Gosub("SIP/fpbx-2-zIetkx3ctJ74-00000093", "app-blacklist-check,s,1()") in new stack
-- Executing [[email protected]:1] GotoIf("SIP/fpbx-2-zIetkx3ctJ74-00000093", "0?blacklisted") in new stack
-- Executing [[email protected]:2] Set("SIP/fpbx-2-zIetkx3ctJ74-00000093", "CALLED_BLACKLIST=1") in new stack
-- Executing [[email protected]:3] Return("SIP/fpbx-2-zIetkx3ctJ74-00000093", "") in new stack
-- Executing [[email protected]:4] Set("SIP/fpbx-2-zIetkx3ctJ74-00000093", "CDR(did)=4193542087") in new stack
-- Executing [[email protected]:5] ExecIf("SIP/fpbx-2-zIetkx3ctJ74-00000093", "0 ?Set(CALLERID(name)=14195753423)") in new stack
-- Executing [[email protected]:6] Set("SIP/fpbx-2-zIetkx3ctJ74-00000093", "CHANNEL(musicclass)=default") in new stack
-- Executing [[email protected]:7] Set("SIP/fpbx-2-zIetkx3ctJ74-00000093", "__MOHCLASS=default") in new stack

[2014-12-03 13:05:59] WARNING[24677][C-0000008a]: func_channel.c:569 func_channel_read: Unknown or unavailable item requested: ‘reversecharge’
[2014-12-03 13:05:59] WARNING[24677][C-0000008a]: func_channel.c:569 func_channel_read: Unknown or unavailable item requested: ‘reversecharge’
– Executing [[email protected]:8] GotoIf(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “0?macro-hangupcall”) in new stack
– Executing [[email protected]:9] Set(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “__CALLINGPRES_SV=allowed_not_screened”) in new stack
– Executing [[email protected]:10] Set(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “CALLERPRES()=allowed_not_screened”) in new stack
– Executing [[email protected]:11] Goto(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “ext-fax,400,1”) in new stack
– Goto (ext-fax,400,1)
– Executing [[email protected]:1] Set(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “FAX_FOR=Receptionist (400)”) in new stack
– Executing [[email protected]:2] NoOp(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “Receiving Fax for: Receptionist (400), From: “Cell Phone OH” <14195753423>”) in new stack
– Executing [[email protected]:3] Set(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “FAX_ATTACH_FORMAT=pdf”) in new stack
– Executing [[email protected]:4] Set(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, "[email protected]") in new stack
– Executing [[email protected]:5] Goto(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “s,receivefax”) in new stack
– Goto (ext-fax,s,3)
– Executing [[email protected]:3] StopPlayTones(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “”) in new stack
[2014-12-03 13:05:59] WARNING[24677][C-0000008a]: pbx.c:4910 pbx_extension_helper: No application ‘ReceiveFAX’ for extension (ext-fax, s, 4)
[2014-12-03 13:05:59] WARNING[24677][C-0000008a]: pbx.c:4910 pbx_extension_helper: No application ‘ReceiveFAX’ for extension (ext-fax, s, 4)
== Spawn extension (ext-fax, s, 4) exited non-zero on ‘SIP/fpbx-2-zIetkx3ctJ74-00000093’
– Executing [[email protected]:1] GotoIf(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “1?failed”) in new stack
– Goto (ext-fax,h,103)
– Executing [[email protected]:103] NoOp(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “FAX for: [email protected] , From: “Cell Phone OH” <14195753423>”) in new stack
– Executing [[email protected]:104] Macro(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “hangupcall,”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/fpbx-2-zIetkx3ctJ74-00000093”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/fpbx-2-zIetkx3ctJ74-00000093’ in macro ‘hangupcall’
== Spawn extension (ext-fax, h, 104) exited non-zero on ‘SIP/fpbx-2-zIetkx3ctJ74-00000093’

Switch back to 11? See if it works

Downgraded to 11 and receivefax shows with “core show applications” and fax works. Any idea on why receivefax isn’t in asterisk 13?

@GameGamer43 ^^^^^^^^

The ReceiveFax and SendFax applications are provided by the generic FAX resource module (res_fax.so). The most likely cause of the issue you’re experiencing is because res_fax.so is unable to parse /etc/asterisk/res_fax.conf. This can be caused by an incorrect configuration such as min/max_rate not being set. You will be able to see this is you do the following in the asterisk cli:

module load res_fax.so

The output will be something like:

Unable to load module res_fax.so
Command 'module load res_fax.so' failed.
[2014-12-03 21:16:34] ERROR[23181]: res_fax.c:1050 fax_rate_str_to_int: failed to sscanf '' to rate
[2014-12-03 21:16:34] ERROR[23181]: res_fax.c:1050 fax_rate_str_to_int: failed to sscanf '' to rate
[2014-12-03 21:16:34] ERROR[23181]: res_fax.c:4596 load_module: failed to load configuration file 'res_fax.conf'
[2014-12-03 21:16:34] ERROR[23181]: res_fax.c:4596 load_module: failed to load configuration file 'res_fax.conf'

To help us determine why this is happen, we need the following output (preferably in a bug ticket for tracking purposes):

  • cat /etc/asterisk/res_fax.conf
  • echo 'SELECT * from fax_details' | amportal a m

Do you want me to switch back to asterisk 13 before I run these commands?

The last two you can run them without switching Asterisk back to 13. In order to see the reason for the failure, you will need to switch back to Asterisk 13 to reproduce the issue.

Here are the last two commands. I’ll switch back to 13 after we close and post the results.
(I obscured the email and phone numbers)

[[email protected] ~]# cat /etc/asterisk/res_fax.conf
[general]
#include res_fax_custom.conf
minrate=2400
maxrate=14400
[[email protected] ~]# echo 'SELECT * from fax_details' | amportal a m

Fetching FreePBX settings with gen_amp_conf.php..

key     value
minrate 2400
maxrate 14400
ecm     yes
legacy_mode     no
force_detection no
sender_address  xxxxxx
fax_rx_email    xxxxxx
headerinfo      RMT Ohio
localstationid  419-xxx-xxxx
modem
maxaction       delete
maxpages        1000
[[email protected] ~]#

I’ll put this in a ticket but I have to get logged in and buy credits.

https://issues.asterisk.org/jira/browse/ASTERISK-22790

https://issues.asterisk.org/jira/browse/ASTERISK-23231

freepbx*CLI> module load res_fax.so
Unable to load module res_fax.so
Command ‘module load res_fax.so’ failed.
== Parsing ‘/etc/asterisk/res_fax.conf’: Found
== Parsing ‘/etc/asterisk/res_fax_custom.conf’: Found
[2014-12-03 17:15:44] ERROR[13842]: res_fax.c:4318 set_config: ‘modems’ setting ‘V17,V27,V29’ is incompatible with ‘minrate’ setting 2400
[2014-12-03 17:15:44] ERROR[13842]: res_fax.c:4318 set_config: ‘modems’ setting ‘V17,V27,V29’ is incompatible with ‘minrate’ setting 2400
[2014-12-03 17:15:44] ERROR[13842]: res_fax.c:4596 load_module: failed to load c onfiguration file ‘res_fax.conf’
[2014-12-03 17:15:44] ERROR[13842]: res_fax.c:4596 load_module: failed to load c onfiguration file ‘res_fax.conf’

So this looks like a change that was made in asterisk but the change never made it to 13?. 2400 isn’t supported with v27 and that prevents the module load so maybe freepbx should remove that value from the list?

Asterisk needs to fix this in 13 as it operates in every other version fine and we can not set baud rates on a per V style. Its global

yeah but if 2400 isn’t a valid option and we don’t have access to the “modem” (v setting) why have it there?

If you feel it’s a bug in FreePBX you can of course report it for free on http://issues.freepbx.org but of course as Tony said it’s primarily an Asterisk bug and should be brought up there as well.

I guess I’ll just let it go. I know the work-around. Thanks for all your help!!