Received incoming SIP connection from unknown peer to


(Anton Loginov) #1

Good afternoon everyone, freepbx 15 installed, new installation. When incoming calls come in the handset, ss-noservice is heard. If I include Allow Anonymous Inbound SIP Calls in sip settings, everything works fine. As I understand it, the asterisk perceives the incoming call from the sip provider as an unknown call. How can this be fixed?
Connected to Asterisk 16.11.1 currently running on freepbx (pid = 2444)
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
> 0x7f0fbc05c960 – Strict RTP learning after remote address set to: 80.75.130.83:49386
– Executing [mynamber@from-sip-external:1] NoOp(“SIP/80.75.130.83-00000042”, “Received incoming SIP connection from unknown peer to mynamber”) in new stack
– Executing [mynamber@from-sip-external:2] Set(“SIP/80.75.130.83-00000042”, “DID=mynamber”) in new stack
– Executing [mynamber@from-sip-external:3] Goto(“SIP/80.75.130.83-00000042”, “s,1”) in new stack
– Goto (from-sip-external,s,1)
– Executing [s@from-sip-external:1] GotoIf(“SIP/80.75.130.83-00000042”, “1?setlanguage:checkanon”) in new stack
– Goto (from-sip-external,s,2)
– Executing [s@from-sip-external:2] Set(“SIP/80.75.130.83-00000042”, “CHANNEL(language)=ru”) in new stack
– Executing [s@from-sip-external:3] GotoIf(“SIP/80.75.130.83-00000042”, “1?noanonymous”) in new stack
– Goto (from-sip-external,s,5)
– Executing [s@from-sip-external:5] Set(“SIP/80.75.130.83-00000042”, “TIMEOUT(absolute)=15”) in new stack
– Channel will hangup at 2020-10-29 11:20:38.975 +05.
– Executing [s@from-sip-external:6] Set(“SIP/80.75.130.83-00000042”, “receveip=recvip”) in new stack
– Executing [s@from-sip-external:7] Log(“SIP/80.75.130.83-00000042”, "WARNING,“Rejecting unknown SIP connection from 80.75.130.83"”) in new stack
[2020-10-29 11:20:23] WARNING[19145][C-0000002b]: Ext. s:7 @ from-sip-external: “Rejecting unknown SIP connection from 80.75.130.83”
– Executing [s@from-sip-external:8] Answer(“SIP/80.75.130.83-00000042”, “”) in new stack
– Executing [s@from-sip-external:9] Wait(“SIP/80.75.130.83-00000042”, “2”) in new stack
> 0x7f0fbc05c960 – Strict RTP switching to RTP target address 80.75.130.83:49386 as source
– Executing [s@from-sip-external:10] Playback(“SIP/80.75.130.83-00000042”, “ss-noservice”) in new stack
– <SIP/80.75.130.83-00000042> Playing ‘ss-noservice.ulaw’ (language ‘ru’)
> 0x7f0fbc05c960 – Strict RTP learning complete - Locking on source address 80.75.130.83:49386
– Executing [s@from-sip-external:11] PlayTones(“SIP/80.75.130.83-00000042”, “congestion”) in new stack
– Executing [s@from-sip-external:12] Congestion(“SIP/80.75.130.83-00000042”, “5”) in new stack
== Spawn extension (from-sip-external, s, 12) exited non-zero on ‘SIP/80.75.130.83-00000042’
– Executing [h@from-sip-external:1] Hangup(“SIP/80.75.130.83-00000042”, “”) in new stack
== Spawn extension (from-sip-external, h, 1) exited non-zero on ‘SIP/80.75.130.83-00000042’
== Using SIP TOS bits 96
== Using SIP CoS mark 4
trunk setting :
Outgoing
username=$
type=friend
secret=$
qualify=3000
insecure=invite,port
host=80.75.130.83
dtmfmode=rfc2833
disallow=all
allow=alaw,ulaw
nat=force_rport,comedia
Incomming
Register String : username:secret@80.75.130.83/myphone


(Itzik) #2

https://wiki.freepbx.org/pages/viewpage.action?pageId=28770440


(Anton Loginov) #3

I read this article and did not find an answer. I’m sorry for my carelessness, but can you point out my mistake


#4

note 2/10


(Anton Loginov) #5

Thank you so much. Now works perfect.You saved my day.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.