Re-routing direct extension calls to a queue

Hello everyone.

Issue is basically with internal calls.

We have a ring group 200 which rings to 201, 202 & 203. Employees were instructed to call 200, but they somehow are still calling the individual extensions.
Se we added the following in extensions_custom.conf for each extension

[from-internal]
exten => 201,1,Answer()
exten => 201,n,Goto(ext-group,200,1)

It worked perfectly fine.

We are trying to set this up with queues.

[from-internal]
exten => 201,1,Answer()
exten => 201,n,Goto(ext-queues,200,1)

But the above is just causing a loop.

Can anyone please guide me how to accomplish this with queues?

Thanks

initial idea deleted

My first idea won’t work. Maybe enable FMFM on the three extensions to forward to ring group 200. I don’t think Ring Groups will use FMFM settings, but test to be sure you don’t loop.

Lorne, thanks for responding.

I did not manage to see your initial idea, so I don’t know what I missed…

As stated in my initial post, it works with Ring Groups, just not with Queues.
So I followed your suggestion and set Queue 200 to not call followme or call fwd, then set in 201 FMFM list to call 200.
It works fine.
However, I need a wait time longer than 60 seconds (max limit of FMFM ring time), I do see in advanced settings that FMFM can ring 120 seconds, but when I set 120 i did not get an option in the actual FMFM settings to increase the ring time for more than 60 seconds.
Newly created extensions is set to 0 and also has a limit of 60s after making this change in advanced settings.

So I added the following in extensions_custom.conf:

[from-internal]
exten => 201,1,answer()
exten => 201,n,Dial(Local/[email protected])

This one works and does not cause a loop.

Question is if this is not going to mess up something?
(I’m not that familiar with Asterisk Dialplan, so could be i’m terribly wrong, and this one is worse than the 1st dialplan I posted…)

Thank you.

I can’t think of any reason why it wouldn’t work, provided it passes your testing. Note that you can change the internal caller id with "CID Num Alias " on the advanced tab of your extensions 201-203 to all show 200.

1 Like

We did that already while setting up the PBX, however, our mistake was by setting the line key to this:


Which allowed users to tell the extension they see on the screen to other employees.

A wish there would be another toggle that says: custom.
Even better, a wish we could edit the line key text within Extension Mapping (section where you can customize the BLF keys), so in scenarios like this, you could just set 3 phones to display the same extension number on the screen.

EDIT: I submitted a feature request for this. Log in - Sangoma Issue Tracker

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.