Raspbx 11-11-2019 and no audio between extension calls in local network

I installed raspbx 11-11-2019 yesterday on a raspberry pi 3B+ and updated everything.
Created two extentions (1000 and 1001) but when i place calls from one to another there is no audio and the call terminates after 30seconds.
All devices (raspbx, computer and iphone) are within local network
I’ve opened the ports on my router pointing to my raspbx ip (10000 - 10100) but still no success.
From further searching, raspbx doesn’t support a firewall module and therefore there’s no ‘Firewall’ option inside the ‘Connectivity’ menu.

How can I solve this issue?
I have run out of ideas.

In Asterisk SIP Settings, confirm that External Address is your public IPv4 address and Local Networks is set to / 24
If you change any of these you must restart (not just reload) Asterisk.

For the (pjsip) extensions, confirm that RTP Symmetric, Rewrite Contact and Force rport are all Yes (these are the defaults but something may have been set up wrong). Set Direct Media to No.

If you had set up chan_sip extensions, please change to pjsip.

In the endpoints, turn off any settings related to NAT, STUN, TURN or ICE.

From each extension, try calling *43 (echo test) and report whether you hear the announcement and whether the echo test works.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a test call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

If things are working properly, an internal call should not involve your router at all. Normally (for external calls) you would forward the default RTP port range of UDP 10000 to 20000. If you set this range smaller, please explain.

I found the solution.
Actually it was on the iphone/softphone.app side.
The RTP range was from 10000 - 60000 , beyond the 10100 i had in my raspbx.
Once I sync’ed them with 10000 - 10100, everything went fine.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.