I am trying this and that to attempt a RAID1 array with a fresh install of FreePBX Distro (latest stable version, 32bit).

I have a RocketRaid 133 from Highpoint with 2 PATA drives both completely cleared of all partitions and data. I am able to create the array using the RR bios. There is nothing to mirror so I just created the array.

I popped in the Distro DVD and during the initial boot, it asks of 3 options: Press Enter (for auto detect of raid array), Freepbx-noraid for simple partitions and Freepbx-advance for advance.

It doesn’t matter which one I pick. After the white text fills the screen, eventually I get:

EIP: [] pci_bus_clock_list+0xd/0x17 SS:ESP 0068:c18a2ee4
<0> Kernel panic - not syncing: Fatal exception

As this is a clean install, I am unsure where to turn.

Any help would be great. Thanks!

EDIT: I should mention that earlier, with my current 1 hard drive build and a stable FreePBX Disto system working, I tried to duplicate the drive in a RAID1 array and mirror the drive (which worked great) but during a boot, I got the same error.

I know the hardware works. I’ve used it since.

I ran your question by one of our Engineers, and here’s what he had to say:

"Cheap RAID cards (RocketRaid 133) are what they consider FakeRaids. They fool the OS to think they are RAID but require a driver to make them work.

Real raid cards work much better ( aka 3Ware, LSI, Adaptec, Dell PERC…)"

So, my recommendation at this point is to invest in a REAL RAID card that will use the embedded firmware of the card vs. a driver to work as a RAID.

Goood luck.


Ok. Thanks! :slight_smile: