Queues Pro not following weighted agents

We are having an issue where queue calls are not moving to the next higher weighted agents. For example: Extensions 2000,0 2001,0 2002,0 2003,1 2004,1 2005,2 2006, 2

When the 0 weighted dynamic agents all log out, the next weighted dynamic agents which are logged in do not get the calls. Instead, the calls are going straight to voicemail even though the higher weighted agents are logged in.

What version of asterisk are you on?

What do you see when you run queue show <queue number> after the agent has logged out?

Freepbx 16.0.40 / Asterisks 18.16

when I run asterisk -rx “queue show 401” it shows the agent logging in when I log them in, but when I log them out it shows nothing.

2003,1 2004,1 2005,2 2006, 2

Are these just registered desk phones? Or is there anything special about these extensions (fmfm, softphone, etc.)

You can also look at the queue logs in freepbx to see what is happening when the call is “stuck” in queue (i.e. is it trying to send the call to agents? Are there errors? etc.)

Asterisk Logfiles - PBX GUI - Documentation (freepbx.org)

These are all regular desk phones. It appears that the only agents that are being called are the agents with the 0 weight, it is not rolling over to the higher weights.

Are the other agents listed in the queue and available to take calls though? You can paste the result of the command here so we can tell if there is something unusual about the output.

Logs will be helpful to understand:
Providing Great Debug - Support Services - Documentation (freepbx.org)

You either need to know an example call or make a new one to capture the full output.

Pastebin is broken, but you can use privatebin https://privatebin.net/

Yes, the more weighted agents are also in the queue, and available,they show up in the logs as joined as well. It is just not rolling over to anything weighted higher than 0. I cannot do any further testing until after close of business. I will post some logs after COB today. I should also probably restart the server after COB today to see if somehow that fixes it. This server has not been restarted in a while. This queue was working perfectly when I first set it up. I have been looking over the settings and can not find anything wrong in the settings whatsoever.

Also would like to mention there are not static queue members. All members are dynamic. Members are required to log in every morning at open.

This is confirmed happening to me.
FreePBX 16.0.40
PBX Distro:12.7.8-2208-2.sng7
Asterisk Version: 16.30.0

I opened a support ticket (Case Number 01358247) on VQ Plus module.
Also opened a bug report just in case: FREEPBX-24175

I have penalty 0 and 1 dynamic agents in queues. The queues logic is not “seeing” the penalty 1 agents. If there are only penalty 1 agents in the queue, callers cannot join the queue. The logs reflect not evening attempting to call any penalty 1 member. If I change an member penalty from 1 to 0, they work just fine.

They look okay from the Asterisk Info screen:
`YYYY has 0 calls (max unlimited) in ‘rrmemory’ strategy (18s holdtime, 739s talktime), W:0, C:4, A:7, SL:100.0%, SL2:72.7% within 60s

RNW (Local/[email protected]/n from hint:[email protected]) with penalty 1 (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet (login was 5948 secs ago)`

The show in the queue log:
2 1683311464|1683311440.8438|YYYY|RNW|ADDMEMBER|

Hint shows them ready:
[email protected]: CUSTOM/XXXXXXXXXX&Cu State:Idle Presence:available Watchers 1

Can anyone else setup a quick queue on 16 with a penalty 1 dynamic agent and see if you have the same issue?

This looks like another potential issue here.

Just to confirm, I have the exact same issue. I can’t test further because my trial access is over (and I was not able to test the product because of this bug…)

Is anyone aware of a workaround? We have several clients that rely on the penalty function to segment calls?

@lgaetz I noticed that there was no open issues on System Dashboard - Sangoma Issue Tracker (freepbx.org) Ive never seen it so… clean… :slight_smile: is there a new bug tracker? Want to make sure I didn’t miss anything.

I updated the bug tracker and case with this thread. I will report back what I hear.

So, I could never get it to work with the weighted agents. What I ended up doing was creating separate queues with the different agents and then failing the queues over from one to the other. I know its the long way of doing this, but it still served the purpose of fixing my existing problem. Hope this helps others.

No updates on the bug tracker or the case as of yet.

Can any FreePBX 16 users do a quick test and setup a queue with a dynamic agent set to penalty 1 and see if it works normally? maybe we can troubleshoot it here.

I tried this on a second pbx I manage and got the same results.

@paraguy Ill update the ticket and bug. What version of FreePBX/Asterisk?