Queues Join Empty set to no/strict not working for Static Agents

Hi,

I am running FreePBX 2.8.0.4 and when we set Queues Join Empty to no or strict there is no effect. Calls are still put into Queue when agents are logged out. Our queues have static agents which is probably what is causing the problem. Please help.

Thanks,
Nate

Asterisk 1.8.1. What do you mean by how am I setting up the queues? Show Queues shows the static agents as such even though they are not currently logged into a device. Also I am running in User and Device mode.

queue show 0000009
0000009 has 0 calls (max unlimited) in ‘rrmemory’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:3, SL:0.0% within 60s
Members:
Local/[email protected]/n (Not in use) has taken no calls yet
Local/[email protected]/n (Not in use) has taken no calls yet
No Callers

Moving to dynamic agents would be a pain because we have a large number of agents that belong to 2 or more queues and they would have to log into each one individually or I would have to setup an agi which would still be much more complicated that just using user & device mode and static agents.

what version of asterisk is this? how are you setting up the queues? it sounds like you have a situation where the queue always has members. when all your agents are logged out, try “show queues” from the CLI to see what asterisk thinks the situation is with the queue. my guess is that it would be better to move to dynamic agents anyway.