Queue wrong agent timeout

Greeting
i have queue settings

[6001]
announce-frequency=0
announce-holdtime=no
announce-position=no
autofill=yes
autopause=no
autopausebusy=no
autopausedelay=0
autopauseunavail=no
joinempty=yes
leavewhenempty=no
maxlen=0
memberdelay=0
min-announce-frequency=15
musicclass=default
penaltymemberslimit=0
periodic-announce-frequency=0
queue-callswaiting=silence/1
queue-thereare=silence/1
queue-youarenext=silence/1
reportholdtime=no
retry=5
ringinuse=yes
servicelevel=300
setinterfacevar=yes
strategy=ringall
timeout=120
timeoutpriority=app
timeoutrestart=no
weight=0
wrapuptime=0
context=

As U see
timeout is 120 sec

but somehow new timeout not working
and it is 15 sec (default)

[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] pbx.c: Executing [[email protected]:50] Queue(“SIP/Primary-00000022”, “6001,t,”) in new stack
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] res_musiconhold.c: Started music on hold, class ‘default’, on channel ‘SIP/Primary-00000022’
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: Called Local/[email protected]/n
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: Called Local/[email protected]/n
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: – LazyMembers debugging - Numbusies: 0, Nummems: 2
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: Local/[email protected];1 is ringing
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: Local/[email protected];1 is ringing
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: Local/[email protected];1 is ringing
[2021-11-08 10:02:15] VERBOSE[53305][C-00000035] app_queue.c: Local/[email protected];1 is ringing
[2021-11-08 10:02:30] VERBOSE[53305][C-00000035] app_queue.c: Nobody picked up in 15000 ms

so anybody knows why timeout in Queue setting not used
but default ring timeout is used
Thanks

maybe you need to check in the SETTINGS --> ADVANCED SETTING --> Ringtime Default

yes Queue use Ringtime Default
but should use timeout set up in Queue
isn`t it ?