Queue toggle not working

Hello,

I installed freepbx distro some days ago (but issue looks more related to freepbx than to the distro itself) and try to use the queue toggle.

I’ve got 2 extensions :

100
222

I’ve got a queue 604

From device 100, if i dial : 45100604

Feature is working fine, user is added in the queue, BFL working too.

From device 100, if i dial 45222604, then user 100 is added or removed from the queue and not 222

Same problem if i move to the other device.
I found on the forum users with same problem, but it looks to me an old problem already solved.

In Asterisk log, when i try to add 222 in the queue from device 100 i see :

– Executing [45222[email protected]:1] Set(“SIP/100-00000021”, “QUEUENO=604”) in new stack
– Executing [45222[email protected]al:2] Goto(“SIP/100-00000021”, “app-queue-toggle,s,start”) in new stack

-- Executing [[email protected]:2] Set("SIP/100-00000022", "AMPUSER=100") in new stack
-- Executing [[email protected]:3] GotoIf("SIP/100-00000022", "0?report") in new stack
-- Executing [[email protected]:4] ExecIf("SIP/100-00000022", "1?Set(REALCALLERIDNUM=100)") in new stack
-- Executing [[email protected]:5] Set("SIP/100-00000022", "AMPUSER=100") in new stack
-- Executing [[email protected]:6] GotoIf("SIP/100-00000022", "0?limit") in new stack

-- Executing [[email protected]:32] Set("SIP/100-00000022", "CDR(cnam)=Accueil") in new stack
-- Executing [[email protected]:33] Set("SIP/100-00000022", "CHANNEL(language)=fr") in new stack
-- Executing [[email protected]:3] Set("SIP/100-00000022", "CALLBACKNUM=100") in new stack
-- Executing [[email protected]:4] RemoveQueueMember("SIP/100-00000022", "604,Local/[email protected]/n") in new stack

[2014-03-29 00:04:54] NOTICE[3848][C-00000021]: app_queue.c:6872 rqm_exec: Removed interface ‘Local/[email protected]/n’ from queue ‘604’
– Executing [[email protected]:5] RemoveQueueMember(“SIP/100-00000022”, “604,Local/[email protected]/n”) in new stack

What’s wrong ? is it related to CALLBACKNUM ?

Queues release is 2.11.0.18

Thank you.

This is for safety. It looks to the caller ID of who is trying to login. The *45 ignores what extension you are passing it and replaced it with what the user that is calling.

Thank you for the information.
I was about to become crazy trying to understand what was wrong in my setup :frowning:

I guess there’s no “elegant” way to change this nor in the advanced options right ?

Just to explain what i was trying to do :

I’ve got an “on-call” emergency service, each week a different employee receive the calls from this number, this call is forwarded to the employee mobile number . Those users don’t have a fixed phone as they’re out of the office all day long.

Each monday, the receptionist must open the “queues” module in Freepbx, change the fixed agent to the new user, save, close, etc …
I try to find a way to do it with soft key on his phone, and, using BLF monitor who is taking care of the calls.

So i thought about creating “fake” extensions for each road warrior , with a follow me rule to his mobile phone.
On the receptionist phone, a dedicated key with BLF to Toggle each user in the queue. This way she just need to press one key to log a user in the queue, and using BLF she can check the status of the queue.

Any alternative idea is really appreciated :smiley:
Thank you very much.