Queue retry time 0 not working (bug?)

Hi guys,

I have a problem with my queue behaviour.
As a ring strategy I use rrmemory with an agent timeout of 10 seconds and a retry value of 0.

When a call is received, the agent phone rings for 10 seconds, then it stops ringing for 5 seconds before ringing again for 10 seconds at another agent and so on.
Where do those 5 seconds come from? I have the retry value at 0 seconds.
When I set the retry value to 1 the time between rings is 1 second, when I set it to 8 seconds, the time between rings is 8 seconds. Only when I set it to 0 the time between rings is 5 seconds?

I tried this on 2 different servers, one with Asterisk 1.8 and FreePBX 2.9 and one with Asterisk 1.8 and FreePBX 2.10.
Also tried switching phones, tried it with Linksys, Snom, XLite, PortSIP.

This looks like a bug to me?
Anyone who can help me out?

I dont think 0 should be a valid entry. I think asterisk is interrupting the 0 as a default which is 5 seconds.

I’ve read some more info on this and according to
this behaviour is correct.

Can I make a feature request for FreePBX so this is shown in the dialog box (don’t know how it is called) that popups when you hover a link in the FreePBX gui?