Queue Reports


#1

Hi,
I tried to get a solution on the Comercial Modules’ Section but had no help at all there.
Maybe i have more luck here in ‘General Help’
This is my issue:
I am using Queue Reports 14.0.7.18.
I had allways an issue with the reports wich is unsolved till now.
On an ‘Answered call Details’ report i have many records with a blank DID field.
I could live with that because i changed the cron job to run every hour.
like this
*/60 * * * * [ -e /var/www/html/admin/modules/qxact_reports/import_queue_data.php ] && php /var/www/html/admin/modules/qxact_reports/import_queue_data.php

That way i had minimized the records with a blank DID field.
With the latest update the records are fetched every 5 min and there is no entry in the
cron job to change the interval.
I tried this
*/60 * * * * /usr/sbin/fwconsole qxactreports --sync
without success.
So,Is there now a wayto change the fetching interval ?
Thanks


(Dave Burgess) #2

The syntax for crontab is
‘minute’ ‘hour’ ‘day’ …

If you want to change the report to run once an hour, decide which minute you want it to run and choose that (0, 22, whatever) and the report will run every hour at that time. If you want to change the frequency to every four hours, you’d say

0 */4 * * * Run_Me....


#3

Thank you
Will try right away.


#4

I added
0 */4 * * * /usr/bin/fwconsole qxactreport --sync
to var/spool/cron/asterisk
but still no luck.
Data are still fetched every 5 mins.
Can someone confirm that the cron job is right ?


(Lorne Gaetz) #5

what is output of

fwconsole job --list | grep qx

#6


#7

Where or how can i edit this entry ?


#8

https://crontab.guru/

Is an interactive and interpretative tool it will tell you

*/60 * * * * …

Won’t work :slight_smile:

Try

crontab -u asterisk - e


#9

Thank you all for your replies.
As far as i can see there is an entry in the database. cron_jobs table.
There is no edit command in the fwconsole job to edit the job.
There is no entry related with the qxact reports in crontab -u asterisk -e.
The only idea i have but not sure if its the right one is to disable the job via
fwconsole job --disable and the add an entry in crontab asterisk.
Does it sound ok ?


(Lorne Gaetz) #10

The cron task is not being triggered by crontab, it is done via the fwconsole job command. I don’t know of a way to control to control the frequency.


(Dave Burgess) #11

@assos40 Sounds like a feature request would be in order


(system) closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.