Queue phones behind NAT agent can't answer the call

I have a queue with static agents and all phones are behind same router.
My freepbx server is on different location and have a public ip address.
Phones are gxp 2124. When you call directly every each phone is working fine. When there is a call from queue randomly agents can’t answer the call. It is definitely NAT related because that happens only behind att dsl router. I have a different internet line from Comcast and there everything work good. I’m wondering does anybody use to have similar issues and if there is some solution.
PBX Firmware: 5.211.65-11
PBX Service Pack:

Can’t answer as in phone is ringing and they can’t pick up, or can’t answer as in their phone doesn’t ring?

If the phone is not ringing, look at your Queue Ring Strategy - the only strategy that will ring all agents on every call is ringall - and other than a very small queue, this is not a very good strategy to use.

If you have individual agents not answering when a call rings to them (common with untrained agents) then it looks like the calls aren’t getting through - since you can always (I assume from your post) call the stations directly, it means they are staying registered and the NAT is letting incoming traffic through - so again, check the strategy.

Can’t answer when phone is ringing - Only all the phones that are behind nat (4 phones)on my ATT DSL. Work fine with Comcast.
Can call all phones and answer from and to phones directly. And can’t answer randomly - that makes it hard to handle.
I don’t know nothing about queue signaling but seams get broken somehow. If I switch phones on the Comcast line Queue works fine.
P.S. ring strategy is ringall

I think it’s time to get a Packet Capture - this is in no way normal behavior and I am willing to bet it’s a NAT problem - Have you ever done a packet capture? You should do one on the Asterisk and one inside the firewall and compare and see if the packets are being sent, but not received.

From your description it sounds like the invite (Ringing) on the phone is making it through, but the response is not making it back so it keeps ringing.


That I’m thinking is from the beginning - NAT issue. I may try to see if dsl router have some “smart” Voip setting and try to disable them.
It is Motorola NVG510. Seems application layer gateway have sip handle by default on and this router have 2 sip lines enabled and not configured. I’ll RTFM.
I may have to look some Asterisk / Motorola related forums about issues and configuration guides if any…
If I found some reasonable solution of course I’ll post it here.
Wherever this is not directly related to Freepbx itself. It is more hardware related. The main line is that this DSL/Router is very common…

Yeah, I have yet to find a Router with “SIP Features” that didn’t mangle what Asterisk was doing - I think Asterisk is too good at NAT Translation and any device just mangles it - maybe other SIP servers need the help, but Asterisk sure doesn’t.

I’m having some of the same issues did you find out the issue? I am not on ATT If I have more than 2 phones accepting que calls it does not work for me.