Queue - only play announcement when users are logged in

queue
Tags: #<Tag:0x00007f70173c1340>

(Nielsl) #1

Hi All,

I want to play an announcement when callers are placed into the queue, but only when agents are logged in. If there are no agents logged in, the user should not be placed in the queue and the “join announcement” should NOT be played. Instead, I then hand the call over to another service announcement saying that there are no agents available to answer the phone, because nobody is logged in.

How can I achieve this? I only want to play the “Join announcement” for the FreePBX queue when there are actual dynamic users logged in.

Thanks
Niels


#2

Look into the ‘join empty’ options for a Queue


(Nielsl) #3

If I set “join empty” to strict, very strict, no or loose the message keeps playing. Are there any other options?


#4

If you select ‘no’ it should send the caller to your ‘fail-over destination’ for that queue, does it not do that ?


(Nielsl) #5

No matter what I fiddle about with the join-empty options, the call hears the join announcement. In this case what happens is:

  • Cal gets picked up by the inbound route
  • Gets routed to a “Welcome” announcement
  • Gets routed to my Queue which has a “Join Announcement”. This announcement gets played, even when I have the “Join Empty” set to No.
  • After this join announcement is played, the call automatically is routed to the Failover destination because there are no agents in my queue.

What I want is the join announcement only to play when there are agents logged in, and for the call to directly go to the failover destination if there are no agents available to log in.


(Itzik) #6

This is likely a bug. You can report bugs at: issues.freepbx.org


(Nielsl) #7

Created a bug report: https://issues.freepbx.org/browse/FREEPBX-22040