Queue -> no "n" Option in freepbx

Unfortunately (why?) freepbx doesn´t give you the possibility to set the n-Option (no retries on timeout) on Queues (Queues-Section under Inbound Call Control).
As this option is a must for me, i’ve edited the corresponding entry in “extensions_additional.conf” like “exten => 602,n,Queue(602,ntr,30)”.
Problem is, as soon as i change something with the webgui, this change will be overwritten and the n is gone. How do i prevent that, respectively solve this matter?
I`m running 2.3.1.0.
Thanks for any help…

I have an queue(generated by freepbx)

[1001]
wrapuptime=0
monitor-format=wav49
monitor-join=yes
music=default
periodic-announce=
periodic-announce-frequency=0
queue-callswaiting=queue-callswaiting
queue-thereare=queue-thereare
queue-youarenext=queue-youarenext
retry=5
strategy=random
timeout=60
queue-thankyou=queue-thankyou
announce-frequency=60
member=Local/[email protected]/n,0
maxlen=10
leavewhenempty=no
joinempty=yes
eventwhencalled=no
eventmemberstatus=no
context=
announce-holdtime=no
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0
member=Local/[email protected]/n,0

I encountered such a phenomenon
sometimes the user In the queue still need waite a long time in the queue , although there are some Availability agents(the Phone is not ringing ) for this queue.

I use trixbox 2.2.12.

Any suggestions? why did this happened?

you should have opened a new thread (2 different problems)…
regarding your problem: your ringing timeout is quite long, try setting it to something like 15 s.

Talos: Im really understanding what this option does: you cant you just set the failover destination to the other queue (and chain your queues together)?

can no one help me out here?

Open an feature request in trac ( http://freepbx.org/trac/timeline ) and someone might do it.

To make the n option stick (until you update the queue module) (but be on all your queues):

In admin/modules/queues/functions.inc.php line 75:

$options = ‘t’;

change to:

$options = ‘tn’;

great, that was the hint i was looking for. Thanks niklas!
I don’t know if i will do a request, it seems i’m the only one who needs that feature…

very usefull hint , thank you very much !
I think this is a very usefull request because you are not the only who need this feature !!!
Marco