Queue disappeared from FreePBX but still in Asterisk

We are running FreePBX on a trixbox 2.2 install (which has Asterisk Everything has been working well (except for extensions getting “locked” occasionally, requiring an asterisk restart). However, today while adding a static queue member to one of our queues (q2), another admin received some sort of DB error (which they were unable to capture) and the queue disappeared from FreePBX.

The queue still exists in Asterisk, and we can receive calls in it, but FreePBX has no knowledge of the queue in the queues page.

Trying to add the queue again results in a message saying the queue already exists.

Looking in the asterisk database, the queues_config table does not have q2. But q1, q3, and q4 still exist.

Looking at the queues_details table, everything for q2 is still there.

I think I could manually add the q2 info back into the queues_config table, but I am wondering if anyone else has ever encountered this?

I’ve tried looking in a few logs, but do not see anything that immediately jumps out as an error message.

Any suggestions?



EDIT: 2008-03-20 18:15 Eastern Time:

I was able to manually add the information back into the queues_config table. All appears to be working properly. Still not sure what happened.

Indeed I have. It seems to of happened when i tried to use a number for the queue name. FreePBX gave me an error, but at the same added the fields to the queue_details table. If you delete the queue_details, you should be able to recreate the queue.

At the time I though it was my imagination, you might want to open a bug.