Queue Calls 'skip busy agent (Queue Calls Only)

Hello,

We have a Queue with the ring strategy set to rrmemory and skip busy agent set to Queue Calls Only. When a member is on an outbound call and a queue call comes in if it was his turn (round robbin with memory) it will skip him and ring the next available user. It seems like there is no difference between setting the skip busy agent to ‘yes’ and ‘queue calls only’. The members are all dynamic and they log in to each queue in case that makes a difference.

Furthermore, when I see a member on an outbound call or any other call that is NOT a queue call, I see the status of the member in the CLI as ‘in use’. For example:

queue show 500
500 has 0 calls (max unlimited) in ‘rrmemory’ strategy (2s holdtime, 23s talktime), W:0, C:778, A:68, SL:72.1% within 60s
Members:
Michael Smith (Local/[email protected]/n) (dynamic) (In use) has taken 5 calls (last was 7 secs ago)

Am I missing something, shouldn’t it be reporting ‘not in use’ if they are on a call that is not part of the queue?

This is freepbx 2.10, Asterisk 1.8.23.1

Thanks

Tried on a clean install of Freepbx 2.11 with same results.

Hi,

Did you find a solution? I need this option to work.

Thanks