Queue Agent Not Authorized in Phone App Module


(Shackbill) #1

We have multiple trunks shared by 2 small companies so we’ve created 2 Queues for incoming calls. We have 3 receptionist handsets that answer the calls between themselves but at times they may not be on duty so we use a key with *45 to disable both queues so the unmanned phone wont ring. However, we would also like to use the Queue Agents API function in order to select just one queue or just to get a visual indicator of which queue is enabled n a particular device.

When we press the button we get the error ‘Queue Agent Not Authorized in Phone App Module for ext xxx’

I have checked the User Management section and ensured ENABLE ACCESS is set (ive tried both Inherit and Yes) and also that the ‘ALLOWED QUEUES’ are selected (ive tired specifying queues and selecting ‘ALL’)

UserAcct

Any advice is appreciated. thanks.

Edit: Using with PBXAct and S505


(Itzik) #2

I believe you need to set ‘Enable Queue Agent Access’ to ‘Yes’


(Shackbill) #3

ok i will give that a try as well. Wont be able to check the phone until Monday morning tho so i will let you know then if it worked thanks for the advice.

As a side note, i think we had this working briefly the other day, then duplicate the template and made some button assignment changes and thats when it started with the error. So i think Inherit was working previously.


(Shackbill) #4

that worked but only after i did a factory reset of the phone. thanks i mustve overlooked changing that as well. Not sure why this used to work as ‘inherit’ Appreciate your assist.

bill