Queue Agent is not Authorized in the Phone Apps module for extension

I am getting this error message when pressing the Queue Agent XML-API button. The extension/user is is a member of one group which is allowed to access phone apps and the queue agent app is in the active list. However, the same error appears even if I override Rest API to apps and Phone Apps to say it is allowed instead of inherited.

Have I missed something or is this an issue with the most recent update?

EDIT Just to add, if I specify the available queues on the extension/user when overriding then it does work but it’s not possible to specify which queues should be available on the group because the GUI doesn’t offer the dropdown menu.

I’d submit a commercial ticket on this. There’s nothing we can do from the user community to help you.

This turned out to be confusion at the GUI, no doubt because there’s many different ways of doing basically the same thing.

If anyone else comes across this:

Make sure your user/extension is a dynamic member of a queue in Modules > Queues > Edit QUEUENAME > Queue Agents > Dynamic Agents. You must have your user/extension be a dynamic member of at least one queue or you will get the “agent not authorized” error when pressing the Phone Apps Queue Agent button.

Also check:

  • The Restapps daemon is started (look on Dashboard). If it’s not running then you can try from SSH fwconsole start restapps
  • You have enabled Phone Apps for the group the user/extension is a member of:
    • Modules > User Management > Groups > Edit GROUPNAME > Phone Apps
      • General > Allow Access: Yes
      • Enable Queues > Queue Agent Access: Yes
      • Ignore the Allowed Queues text box
  • The user/extension’s Phone Apps Queue settings are set to “inherit” in Modules > User Management > Edit USER > Phone Apps
    • General > Allow Access: Inherit
    • Queues > Enable Queue Agent Access: Inherit
    • Ignore the Allowed Queues text box on this tab too

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.