Queue agent follow me not working correctly

the situation:

  1. agent has a desk phone
  2. agent sometimes works from home on a cell phone
  3. agent added the cell phone number as a follow me to his desk phone
  4. queue settings “skip busy agents” is set to Yes+(ringinuse=no) - the help text for this setting says “When set to ‘Yes + (ringinuse=no)’ the queue configuration flag ‘ringinuse=no’ is set for this queue in addition to the phone’s device status being monitored. This results in the queue tracking remote agents (agents who are a remote PSTN phone, called through Follow-Me, and other means) as well as PBX connected agents, so the queue will not attempt to send another call if they are already on a call from any queue.”

However when a queue call comes in and the agent is working from home, the system will successfully call his cell phone but the system does not seem to track the fact that the ext/follow me is busy. with the result that if the agent is on a queue call on his cell phone and a second queue call comes in, the system will ring his deskphone and his cell phone.

this looks like a bug to me but before i open a ticket i thought i would see if anyone on here has any input.

If this is not working it would seem to be a asterisk bug as that is a asterisk setting so not sure opening bug with us would help at all. I could be wrong here but ringinuse is part of app_queue.

1 Like