Queue Add Member Syntax (With Display Name) for Asterisk CLI

Hello - I am trying to figure out how to add extension to a queue including the display name of the extension. I am able to add extension but only the extension number shows not the display name.

When agents like John Smith below log-in from their phone using a feature code, their entry in the queue when I run “queue show” looks like this:

John Smith (Local/[email protected]/n from hint:[email protected]) (ringinuse disabled) (dynamic) (Not in use) has taken 2 calls (last was 4424 secs ago)

When I try adding an extension through the Asterisk CLI using: queue add member Local/[email protected]/n to 200

The entry after running “queue show” looks like this:
Local/[email protected]/n (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet

What syntax do I need to make the entry from CLI match that of the extension logging in from the phone?

This will be helpful so we can monitor who is in and out of the queue using the “queue show” command. Thank you in advance for your help.

You’re not using all the options of the command. You’re missing the membername field.


Usage: queue add member <channel> to <queue> [[[penalty <penalty>] as <membername>] state_interface < interface >]

Thanks for your reply Tom. Yes I tried to format that with that syntax but wasn’t able to get the command to process. Would you be able to type an example with just dummy data? I really appreciate your help.

Show what you tried.

I have the same issue on a new install, while on another PBX the save exact command works fine.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.