Questions Update Scripts


Last night I ran one of the 10.13 upgrade scripts - so, I was on 10.13.66-12 and ran

One thing that worried me was that pretty much 90% of the OS packages, from were getting 404’s. The script just moved on, and not sure it actually did try any other mirrors - in the end, I have a very long list of failed packages. Not sure what fall out this is going to cause me today now that we’re back in production.

Also, it went and reinstalled a heap of GUI Modules that I had previously uninstalled. Why? It’s installed all of them, every one. I understand why it might want to update GUI modules, prior to doing other updates - but why go and install a heap of stuff I wasn’t nor did want to use? I realised that the upgrade script really only installed iSymphony Server, and I suppose some OS packages (if, the repo had actually worked).

So, here’s the questions…

  1. If I do the next update script 10.13.66-14 - given that the 10.13.66-13 script missed sooo many OS packages - am I going to destroy something?! Should I re-run the 10.13.66-13 script and ensure that OS packages actually get updated before moving onto the next one?
  2. Is it possible to get the script to NOT reinstall missing or uninstalled modules? This is just annoying. Or, maybe the script can skip the module update section altogether (I could just comment all of that part out, I guess), and what will that go on to break?


Changed the command from installall to upgradeall in the first stage. Seems to be working now where instead of installing everything it will just upgrade the modules that are currently installed. Much better.

I notice in the script I am using now, the yum repo is mirrorlist instead of just yum.freepbxdistro. This is an older 6.12 script, so I will check out the 10.13 script and see what repo it was using.

Okay … thought it might’ve just been a once off thing but again the Misc RPM’s part of the upgrade script is hitting 404.

The versions of these rpm’s is completely different to what’s at

For example;

 Package                             Arch         Version                                                                   Repository     Size
 kernel                              x86_64       2.6.32-642.6.2.el6                                                        updates        32 M
 kernel-devel                        x86_64       2.6.32-642.6.2.el6                                                        updates        11 M

But, the version at the repo URL above is kernel-2.6.32-504.el6.x86_64.rpm

Okay so I am no linux expert here so this might just be normal - but why is yum looking for a higher version than what’s on the repo?

I just worry that the upgrade scripts are going to create some headache for me. I am upgrading to fix a nasty bug in Asterisk 13.11 that I was running. The Asterisk RPM updates in the script work fine, I can see that they downloaded no problems and downloaded 13.12.2. Could it be that I am already up to date with the above example package? Then, why wouldn’t it just skip trying to download that package, wouldn’t yum say “No update available”?

The confusion is worse. Last week I did a HEAP of these upgrades on a FreePBX 12 box - upgraded all the way from early 6.12 release to latest 10.13 release, even upgraded Asterisk from 12 to 13 with no problems at ALL.

Yet, this box, for some reason is throwing errors?!

Could it possibly be that someone else may have run a yum update? (Possible one of our sys admins did a yum update after installing).

Hmmmm… is this something to explain why?

updates                                                                                                                  | 1.3 kB     00:00
Not using downloaded repomd.xml because it is older than what we have:
  Current   : Sat Nov 12 16:48:25 2016
  Downloaded: Sun Oct 30 02:46:58 2016