Question about the file /etc/asterisk/chan_dahdi.c

hi , i want to ask about the file
/etc/asterisk/chan_dahdi.conf

assume i have dahdi 1 and dhadhi 2

note that if i applied a config in the file /etc/asterisk/chan_dahdi.conf , these configs will be applied to both dahdi 1 & dahdi 2

assume i want to set to dahdi 1 busycount=10 and i want to put on dahdi 2 busycout = 5

how can i do that ??

i cant to it with the file /etc/asterisk/chan_dahdi.conf

is there individual file for each dahdi line ??

regards

The busycount setting in chan_dahdi.conf is the default setting, but you can also control busycount by individual DAHDI channel; probably in the file dahdi-channels.conf. For example, the settings for DAHDI Channel 4 from my system would be set like this:

;;; line="4 WCTDM/4/3 FXSKS (In use)" signalling=fxs_ks callerid=asreceived group=0 context=from-zaptel busycount=3 channel => 4

The busycount for channel 4 will be set as shown instead of the default value in chan_dahdi.conf

thank you thank youthank you thank youthank you thank youthank you thank youthank you thank youthank you thank youthank you thank youthank you thank youthank you thank you

hi , but i want to ask , how to let the changes take the effect ???

Enter ‘amportal stop’ then ‘service dahdi restart’ then ‘amportal start’ from the command line.

hi ,
i found that if i put the new line
;;; line="4 WCTDM/4/3 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 4
busycount=3

it didnt work
but when i put the line
as below :
i found that if i put the new line
;;; line="4 WCTDM/4/3 FXSKS (In use)"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
busycount=3
channel => 4

it succeeded , i mean that the line must be added before channel => 4 line

thanks alot

regards

hi ,
but i have a problem after applying the busycount in the file dahdi-channels.conf
actaually i have 10 dahdi all of fx0 ports .
after modifying the busycount = 13 only to dahdi 5 & dahdi 9
it seems that applied to dahdi 5,6,7,8,9 !!!

i dont know why that occured !!!
here is the config files :

===========================================================
[[email protected] ~]# cat /etc/asterisk/dahdi-channels.conf
; Autogenerated by /usr/sbin/dahdi_genconf on Thu Nov 29 08:15:23 2012
; If you edit this file and execute /usr/sbin/dahdi_genconf again,
; your manual changes will be LOST.
; Dahdi Channels Configurations (chan_dahdi.conf)
;
; This is not intended to be a complete chan_dahdi.conf. Rather, it is intended
; to be #include-d by /etc/chan_dahdi.conf that will include the global settings
;

; Span 1: ATCOM-1600P/16 “ATCOM AX1600P/800P Board 17” (MASTER)
;;; line="1 ATCOM-1600P/16/0 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 1
callerid=
group=
context=default

;;; line="2 ATCOM-1600P/16/1 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 2
callerid=
group=
context=default

;;; line="3 ATCOM-1600P/16/2 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 3
callerid=
group=
context=default

;;; line="4 ATCOM-1600P/16/3 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 4
callerid=
group=
context=default

;;; line="5 ATCOM-1600P/16/4 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
busycount=13
channel => 5
callerid=
group=
context=default

;;; line="6 ATCOM-1600P/16/5 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 6
callerid=
group=
context=default

;;; line="7 ATCOM-1600P/16/6 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 7
callerid=
group=
context=default

;;; line="8 ATCOM-1600P/16/7 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 8
callerid=
group=
context=default

;;; line="9 ATCOM-1600P/16/8 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
busycount=13
channel => 9
callerid=
group=
context=default

;;; line="10 ATCOM-1600P/16/9 FXSKS"
signalling=fxs_ks
callerid=asreceived
group=0
context=from-zaptel
channel => 10
callerid=
group=
context=default

====================
[[email protected] ~]# cat /etc/asterisk/chan_dahdi.conf
[trunkgroups]
[channels]
context=from-pstn
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
canpark=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
faxdetect=both
;echotraining=800
;rxgain=0.0
;txgain=0.0
rxgain=1.2
txgain=2.5
callgroup=1
pickupgroup=1

;answeronpolarityswitch=no
;hanguponpolarityswitch=yes

faxbuffers=>6,full
echotraining=no
;Uncomment these lines if you have problems with the disconection of your analog lines
busydetect=yes

;busycount=13
busycount=4
;busycount=8 ; after using this , it mad an echo ;
;using 4 it no autohangup , but there is interrupt when calling outbound calls
;busypattern=500,500
;hanguponpolarityswitch=no
;cidstart=polarity
;cidstart=ring
;when using cidstart=dtmf , the calls are no longer being recived on server
;hanguponpolarityswitch=no
immediate=yes
;ringtimeout=5000
;cidsignalling=dtmf
;cidstart=ring
;cidstart=ring
;cidsignalling=fsk
;callwait=yes

;callprogress=yes
;progzone=us
#include dahdi-channels.conf
#include chan_dahdi_additional.conf

Once you set the busycount setting, it will apply to all channels that follow. You need to manually set the busycount for channels 6, 7, and 8 in dahdi-channels.conf

hi , u r right ,
when i put it manually for all channels … it succeeded .

again ,

thanks a lot for u and all who helped and to freepbx forums .

regards