Q: How-to: Enable BOTH UDP and TCP (old) FreePBX 2.11 (SOLVED)

Anyone remember how to do this?

We have a few (still left in production) (working fine) hosted FPBX 2.11 builds in a co-location.
All phones are remote: using 5060/UDP, but now we’d like to use 5060/TCP … we have no desire yet for TLS (or) VPN.

They are all chan_SIP only: using Asterisk 11.x.x. versions.

Right now, port 5060 works with UDP only, but we would like this to work with TCP as well.

There is no options under: Advanced Settings or Advanced SIP settings to allow TCP with UDP

Any tips for allowing both UDP and TCP on port 5060 as transports for chan_SIP?

Thanks for your tips and suggestions.

Using newer FPBX or SangomaOS builds, we see how enabling TCP is rather straight-forward and easy (for) either chan_SIP or chan_PJSIP, but this way is not available under the old 2.11 UI

Perhaps you should consider moving on from a 9 year old version of FreePBX and a 10 year old version of asterisk, not totally unsurprisingly they both ‘got better’ since then :wink:

Maybe: but it is not as easy as that at times.

I even mentioned this in the original post.
I know 2.11 is long gone … It is still working and valid for some.

Do you know if 2.11 supported both TCP and UDP for 5060?

Ah: what a nice Friday:

It seems the ISPs equipment was blocking UDP / 5060 and the Yealink phone is now back online using UDP / 5060.

This is super-cool, but for the days ahead: if you know the answer … thanks for any reply.

Probably but I won’t go back 10 years for you. Neglecting your customers for that long is only your ‘oopsy’ , don’t expect too much sympathy here,

Your reply is both incorrect and valid (ain’t that something).

If the PBX works at 2.11 and nothing else new is needed …
Leave it be: esp it if it has worked with nothing major happening for over 5 years. Rocking and rolling … that is rather FAR from neglect.

You keep patching your boxes and leaving them open for the updates all you want: doesn’t mean what I’m doing is not a valid technique.

I do like you, sir: been following your posts for a while now.

By neglect I mean you ignored what your responsibilities as a provider are , we generally check at least weekly if not daily the health of our systems and burgeoning concerns they might have , updating 2.11 to something vaguely current , hmm … you might have missed that opportunity a few years ago.

yes: point taken

Here is the fix: if others want to know (3 steps)

#1 vi /etc/asterisk/sip_general_custom
(file is probably empty) (add)

#2: In the extensions page (UI) make sure the transport type for each desired extension is set to: TCP only
default is: UDP only

#3: More than likely you’ll need an iptables entry to allow TCP

-A INPUT -p tcp -m tcp --dport 5060 -j ACCEPT

Also: be sure to run from the Asterisk CLI

sip reload

The phone registered using TCP/5060

None of that is necessary in current FreePBX it can all be done in the gui, but some other tardigrades might yet thank you :wink:

Says the wanna-be cutting-edge referee of all things FPBX.

Gotta let you know, freepbx 2.11 is not in any way ‘cutting edge’ .

I am not particularly cutting edge, but I can assure you it works for everybody else but apparently not you.

Time for pause or self consideration perhaps ?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.