Public IP clients not registering

Greetings,

I’ve been trying to add a public ip client for a remote office to our system. So far, the client cannot successfully register.

The far side client is on a static IP address, with a standard SOHO type router. The client phone behind the router is either a Cisco 7940G or Aastra 480i (tried both, neither worked).

Under “Asterisk SIP Settings” in FreePBX I’ve set:

NAT: No
IP Configuration: Public IP

In the system firewall, I’ve allowed tftp, port 5060, and ports 10000:20000 for the specific public IP of the client.

Unfortunately, the phone doesn’t register. There are no entries at all in the asterisk log (no rejections, failures, nothing). It’s like it’s being blocked by the firewall, though the firewall has been explicitly configured to allow the traffic. I even tried shutting down the firewall service completely, with no success.

Any suggestions as to what I’ve missed or done wrong?

  1. sip settings - nat=yes
  2. verify that nat is on in the extension settings
  3. if fail to ban is running, perhaps your remote phone is getting banned (check the log files) - you might want to turn this off temporarily
  4. turn off iptables temporarily
  5. set the verbosity up on the tftp server
  6. tail -f /var/log/messages while rebooting the remote phone - this will tell you if the phone ever tried to pull a config from the pbx