Provisioning Yealink Phones Cfg files not found?

Whatever I do. I try and try to get these phones to provision. They pull their mac based cfg file but they never get their y0000000xx.cfg files. And I’ve read everywhere on these forums for answers. I can’t get EPM to generate them. How do I make it happen?

t23g works. T29g works. Without these files. But t27p do not want to work at all. I monitor the TFtp verbose feed. They just can’t find the file.

Any help?

No help? Nobody knows why those files dont exist or dont get rebuilt in /tftpboot?

Are you using Commercial EPM or OSS one?

Using the commercial endpoint manager. By sangoma.

The only thing I can say is we did move the server from a VM to a new physical server using backup / restore. Which I don’t think should be a issue. It should create these files yes? Even though.

One thing I did notice. The “yealink” folder was not there. And I created it and changed the permissions and then it filled in the firmwares when I uninstalled and installed the firmware versions…

Go save your global setting page. FreePBX backuo and restore with config backup only does not take anything in tftpboot.

Also make sure tftpboot is owned by asterisk user.

@tonyclewis, so here is my directories. I went to the global settings and hit “Save Global” and nothing changed in the directory. Also downgraded asterisk from 13 to 11 to see if that helped… and also again have down “fwconsole chown” several times to see if that changes anything with no help. Tried current EndPoint manager and even the “Edge” version, and then downgraded back to the current version.

Current Asterisk Version: 11.23.1
EndPoint Manager

We dont set y0000000xx.cfg configs as we do everything in each phones mac.cfg. Yealink phones have never needed a y0000000xx.cfg

@tango freepbx has made y0000000xx.cfg files in the past. And I’m told by many it suppose to generate them. I can send you YouTube videos of people setting up freepbx and these files show up on a fresh install with end point manager.

They only show up when using our Phone Apps with our login hot desk feature but to provision a standard phone they are not used.

25 mins into it.

check your backup. i bet you did not back up tftpboot like tony has suggested. if that is the case, then you may need to rebuild your endpoints.

Again that config is not needed. If the phone is not getting its mac.cfg then its a bug with Yealink as that config has nothing in it and only used when we log a phone out using our hot desking.

Troubleshoot your tftpd, turn on logging Instructions

At cmd prompt type tail -f /var/log/messages | grep in.tftpd

Reboot a phone and see if it requests the y0000000xx.cfg file.

One thing I discovered is that all letters in the filename need to be lowercase for both the y0000000xx.cfg and the MAC.cfg

Also have you tried manually creating a y0000000xx.cfg from the examples on the Yealink website.

As others have said, I don’t think you need a y0000000xx.cfg, but it useful for global settings you want on each phone, ie time and date settings, network settings etc