Provisioning T46G help please

I’m currently using FreePBX 12.7.4-1710-2.sng7 and PBX Service Pack I’m also using Sysadmin Pro and Endpoint Manager Pro.

I’ve created a template for this T46G phone and I’ve configured the template and DHCP scope for this VLAN and have set option 66 as the FreePBX internal IP address in the scope. I can’t link anything to my screen caps because I’m new but I can tell you that in my template config shows the destination address as the Internal IP of the FreePBX server, Provisioning Server Protocol is set to tftp and Provisioning Server Address is set to the internal IP of the FreePBX server.

The phone reboots and grabs a DHCP address just fine. I can ping the phone from the FreePBX command line and I see that there is a .cfg file with the MAC address in /tftpboot/ for this phone. When I type service xinetd status it comes up as active running.

I don’t know what else to try here as I’m stumped. I’m not great with linux so if there is something specific anyone needs to see let me know what command to run and I can post the results of that.

Using tail -f /var/log/messages | grep in.tftpd I can see the RRQ from my phone at looking for y000000000028.cfg and returning a file not found error. Is there someplace I can get this file to add back to the /tftpboot/ folder?

Thank you!

The y*.cfg files are generated automatically by EPM. Do you have one of your Yealink templates set as default?

Sorry for the delay in getting back due to the holiday.

I did make the only template I have so far the default internal template but running tail -f /var/log/messages | grep in.tftpd shoes the failure from my phone IP looking for that y000000000028.cfg file and getting a “file not found” error

Tail results

EPM Template

I think a support ticket is in order for this, of type ‘FreePBX Commercial Modules’.

Will do!

Where can I submit a ticket please? I feel like a goof that I can’t find it. If I click on support I’m presented with options for POMPs Gold and POMPs Platinum.

Please disregard, I found it :slight_smile:

Login to and click support from the left hand menu.

Is this a new installation? If so did you setup option 66 on the DHCP to point to your phone server IP address?

As well you did setup the Model template with everything. I have seen some weird bugs that just copying the template to a new template and applying that in Extension Mapping fixes when phones cant find their template.

Brand new install, option 66 working and phones are getting DHCP properly. Oddly enough, right before clicking submit on the ticket I tried one more time and watched the logs and it worked. I changed nothing. Weird, but it’s working so I’m good to go right now. I have a couple of other questions but I’ll start a new thread because it isn’t about Provisioning the T46G anymore.

1 Like