Provider rejects our FROM Header an CID should have an special header format


we´ve switched to a new VOIP Provider. We cannot do any more outbound calls, and the support told us that our SIP FROM header ist wrong formated.

Now it looks like that

Audio is at port 24116 Adding codec 0x4 (ulaw) to SDP Adding codec 0x8 (alaw) to SDP Adding non-codec 0x1 (telephone-event) to SDP Reliably Transmitting (NAT) to INVITE sip:[email protected] SIP/2.0 Via: SIP/2.0/UDP;branch=z9hG4bK2f92dd85;rport From: "49781234ournumber"<sip:[email protected]>;tag=as360b0ab2 To: <sip:[email protected]> Contact: <sip:[email protected]> Call-ID: [email protected] CSeq: 103 INVITE User-Agent: FPBX-2.8.1( Max-Forwards: 70 Our providers says the FROM Line should look like:

<sip:[email protected]>

The second problem ist where i can set our callerid so it looks like this:

P-Preferred-Identity: sip:[email protected]

Thanks for helping me.


Thanks for your reply. I have now managed get this working with


now all is working like expected.

Greetings Mysterious.

As a general rule, if your provider can’t actually tell you configuration instructions for Asterisk, you may want to think about a more ‘Asterisk Friendly’ provider because this could be only the beginnings of your problems with them…

If I’m not mistaken, the From header can be changed by setting the ‘fromuser’ setting in the outbound trunk.

I don’t think the P-Preferred-Indentiy is standard, especially in that format. The two most common ways to assert your identity would be to set the ‘sendrpid’ to either yes (or in 1.8 to pai if that is the format the carrier wanted it). If they need something special, unless there is a setting I’m not aware of, you will have to create the header yourself.

If you need to do it custom, then see the other active thread in the form about someone wanting to add a diversion header, the same principle would apply but with your desired header.