Prosody won't start

FreePBX_Distro

XMPP Module purchased and installed
XMPP server configured as: localhost
user created in User Management

can’t connect with a client using

[email protected]
password
server:

if I ssh into the FreePBX_distro box and issue:

/etc/init.d/prosody restart

I get this:

Stopping prosody:


A problem occured while reading the config file /etc/prosody/prosody.cfg.lua
Error: Error loading included /etc/asterisk/prosody_additional.conf: /etc/asterisk/prosody_additional.conf: No such file or directory

More help on configuring Prosody can be found at http://prosody.im/doc/configure
Good luck!


                                                       [FAILED]

Starting prosody:


A problem occured while reading the config file /etc/prosody/prosody.cfg.lua
Error: Error loading included /etc/asterisk/prosody_additional.conf: /etc/asterisk/prosody_additional.conf: No such file or directory

More help on configuring Prosody can be found at http://prosody.im/doc/configure
Good luck!


                                                       [FAILED]

/etc/asterisk/prosody_addition.conf exists but is empty. I suspect I may need to manually modify this but can’t figure out what needs to go there.

Ultimately I’d like to get IM and video chat working.

Ok, found the issue with prosody not starting, when the XMPP license is installed and you first get into the module config the server is already named “localhost.” I simply figured this was fine.

The problem is that the /etc/asterisk/prosody_additional.conf does not get written unless you actually change this and then apply.

Now that it’s running I can’t connect with client. the prosody.log shows the following:

Apr 28 08:26:31 c2s10e8240 info Client connected
Apr 28 08:26:31 c2s10e8240 info c2s stream for <192.168.1.58> closed: This server does not serve 192.168.1.8

I have the XMPP server set as “localhost”

so the login must match the domain set in the xmpp module exactly. I’ve seen that in prosody you can add “virtual” domains but there isn’t anywhere I can see to do this with the XMPP module and editing the prosody_additional.conf manually is a no no…

so I’ve set the domain to mydomain.com (actual domain hidden), put the proper public dns records in place, set the firewall passthrough.

I can connect to the XMPP with Bria3 clients both inside and outside of my local network but I’m now getting these errors:

s2soutf553d0 info sending error replies for 1 queued stanzas because of failed outgoing connection to proxy.mydomain.com

Anyone have a clue what this means?

problem solved… it was a combination of client confusion and needing to reset the system for changes apparently…

Hi

I’ve also purchased and setup the xmpp module for my domain. however I can not connect internally or externally, I get the same error, this server does not serve domain.com.

I’m using bria for iPhone. but the issue seems to be on the FreePBX side rather than iPhone side.

Any help will be appreciated.

did you read my post in this thread with timestamp 6:55?

what specific error are you getting? what settings are you using on both the xmpp module and bria?