Problems with sangomacrm REST settings


I currently have a test freepbx installation for the company I am contracting to. They need an ACD system setup.

One of the requirements is to have some integration with the ticketing system (zendesk). I’ve managed to get AGI scripting to work with Zendesk for calling from IVR etc , but I’m having some issues with the sangomacrm link module.

I have obtained a 1 month free license. Managed to get it installed after some trouble via fwconsole, installing both zulu and sangomacrm edge versions fixed it.

So far so good. However when I switch the crm module settings to REST (there is no option for zendesk , so have to use the generic setting) it then redirects me to another page for the REST settings.

This link however is broken…

Module Not Found

We are unable to find any information on the module you are looking for.

url is mysubdomain/admin/config.php?display=sangomacrmrest

Getting this working is going to be a crucial selling point for freepbx , the other option is 3cx , which only has very rudimentary zendesk implementation (and is more expensive).

Any ideas?

Thanks in advance

The link should take you to the menu item, Settings → CRM API Settings:

Thanks Lorne,
The link isn’t in the settings menu either. I only have “CRM settings”

Well that is unexpected. Update to edge with:

fwconsole ma upgrade sangomacrm --edge
fwconsole r

If problem persists take two asprin open a commercial module ticket:

Yep still no luck. Options just missing altogether.

Won’t be logging a commercial ticket until they approve buying the licenses, so its a bit of a catch 22 here…

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.