Problems with IVR


I am a relative newbie. I have a problem:
I have ELastix on my machine and have upgraded to FreePBX 2.5.1. It works great ,except for the IVR. I have installed a test IVR and when the number is called ( SIP Trunk). It answers but I am not able to:

  1. Dial any extension during the message
  2. The IVR does not react when options digit are pressed: i-e Pressing 1 doeesn’t do anything. IVR loops over and call is finally hung-up.

What do you think is the roblem. It is my first dab at IVR/Digital Receptionist.

Thanks ina dvance



Problem solved. The SIP Trunk wasn’t passing DTMF digits properly. Changed Trunk, problem solved


This is a intermittent problem, latest version pbx in a flash, freepbx,
ivr not excepting input digits just recycle message, the only fix is to amportal restart. Everything is normal for about 2-3 weeks. Using a tdm board 4-port.



your board uses POTS lines which can only do dtmf in inband mode.

If your volume levels are to high or to low you can hive a problem. to low it can’t hear the tones. If the audio volume has been set to high then it get’s clipped off and the tones will not be heard.

So start be checking there and make sure that the volume is middle of the road.