Problems with CRM install

I am trying to install CRM from gui but there seems to be permission errors, so I’m trying the command line.
fwconsole ma install crm but that seem to be the wrong name, does anyone know the correct module name to use in the command line.

Gary.

Permission errors will almost always be fixed with:

fwconsole chown

You can install CRM from bash with:

fwconsole ma downloadinstall sangomacrm

Thanks Lorne for the reply but I still get install errors on the command line.

[[email protected] ~]# fwconsole ma downloadinstall sangomacrm
No repos specified, using: [standard,commercial] from last GUI settings

Starting sangomacrm download…
Processing sangomacrm
Verifying local module download…Verified
Extracting…Done
Module sangomacrm successfully downloaded
PHP Fatal error: Class ‘Requests’ not found in /var/www/html/admin/modules/sangomacrm/includes/sangoma/zoho/src/Base.php on line 37
Whoops\Exception\ErrorException: Class ‘Requests’ not found in file /var/www/html/admin/modules/sangomacrm/includes/sangoma/zoho/src/Base.php on line 37
Stack trace:

  1. () /var/www/html/admin/modules/sangomacrm/includes/sangoma/zoho/src/Base.php:37
    [[email protected] ~]#

Try this:

fwconsole ma --edge downloadinstall sangomacrm

That worked, Thanks,

1 Like