Problems with calls - can't hear caller or don't receive calls


we’re running FreePBX with some PJSIP (Telekom) in our small business
on a virtual machine and until now everything seems to be fine, except small problems:

  • 1.) Sometimes we can’t hear the caller or the caller can’t hear us, sometimes both, but none of them everytime

  • 2.) After a few hours or a few days after the last reboot we don’t receive any calls
    and we can’t call anyone outside. Telephone seems to be dead.

Actually I am temporary fixing this by simply reboot the virtual machine
and everything works fine for the next undecided time.

The host of the virtual machine is directly connected by lan to a zyxel speedlink 5501 router.

Currently I can’t show any error reporting because until our last reboot today
everything is fine again, but of course I will notice and post them here.

Thanks in advance.

One-way audio issues are typically a problem with NAT settings on your firewall/router. Please ensure that you have your external IP set correctly and that you are forwarding the appropriate RTP ports (typically ports 10000 to 20000 UDP) from the router to your PBX.


thanks for your answer. I forward 5060-5070 (both tcp and udp) and 10000 - 20000 (bot tcp and udp) from the router to our PBX for testing. I reviewed our settings:

1.) under SIP Settings -> Default SIP Settings -> NAT Settings
everything is blank (also unfilled external address and local networks)
and RTP Port Ranges is set to 10000 - 10100

Question: Should I fill all the settings and update the RTP Port Range to 10000 - 20000?

2.) Under SIP Settings -> SIP Settings [chan_pjsip]
I can’t see anything relevant except:

  • (udp) Settings. “Domain the transport comes from”, “external ip address” and
    “local network” - everything is unfilled.

Should I correct them too with the right settings? If yes, what is the “domain the
transport comes from”?

3.) Under SIP settings -> SIP Legacy Settings [chan_sip] -> NAT Settings
NAT is set to yes and “ip configuration” is static, “override external ip” is
set to our public office ip.

We’re using PJSIPs, so I can’t find any settings for RTP Ports in chan_pjsip, only in chan_sip.

Thanks in advance for help, would love to hear from you.

Kind regards

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.