Problems with caller ID blocking

Hello,

I have a PJSIP trunk with voip.ms and I’m trying to set up outbound caller ID blocking. I’ve set up an outbound route matching calls starting with *67, and configured the caller ID on this route as “hidden” using my valid DID number. The problem is that voip.ms blocks these calls because the caller ID number is not sent, which voip.ms requires. I contacted their support, and they indicated that I must pass a valid Caller ID number and set the “privacy=on” flag in the Remote-Party-ID SIP header to instruct voip.ms to hide my number. I’m not sure how to do this. I enabled Send RPID/PAI in the PJSIP trunk options, but this didn’t help.

Using tcpdump, I’ve confirmed that when I set “hidden” in the Caller ID field, FreePBX does not send the Remote-Party-ID field even if it’s enabled in the trunk PJSIP options:

raspbx.home.lan.sip > <voipms-server>.sip: [udp sum ok] SIP, length: 941
    INVITE sip:<number>@<server>:5060 SIP/2.0
    Via: SIP/2.0/UDP <my-IP>:5060;rport;branch=z9hG4bKPj7911f74a-e1db-471f-991f-75261e935ffb
    From: "Anonymous" <sip:[email protected]>;tag=52ac39b5-4095-4e6e-a7c2-2d8f39859a2e
    To: <sip:<number>@<server>>
    Contact: <sip:[email protected]<my-IP>:5060>
    Call-ID: <call-ID>
    CSeq: 699 INVITE
    Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
    Supported: 100rel, timer, replaces, norefersub
    Session-Expires: 1800
    Min-SE: 90
    Max-Forwards: 70
    User-Agent: FPBX-15.0.16.49(16.9.0)
    Content-Type: application/sdp
    Content-Length:   241

    v=0
    o=- 1897907294 1897907294 IN IP4 <my-IP>
    s=Asterisk
    c=IN IP4 <my-IP>
    t=0 0
    m=audio 19480 RTP/AVP 0 101
    a=rtpmap:0 PCMU/8000
    a=rtpmap:101 telephone-event/8000
    a=fmtp:101 0-16
    a=ptime:20
    a=maxptime:150
    a=sendrecv

However, if I don’t set “hidden” in the Caller ID field, then the Remote-Party-ID is added as expected but Privacy is set to off, not on. voip.ms needs for it to be ON to hide the caller ID, and I don’t know how to do this.

22:14:57.742357 IP (tos 0x60, ttl 64, id 8587, offset 0, flags [DF], proto UDP (17), length 1050)
    raspbx.home.lan.sip > <voipms-server>.sip: [udp sum ok] SIP, length: 1022
        INVITE sip:<number>@<voipms-server>:5060 SIP/2.0
        Via: SIP/2.0/UDP <my-IP>:5060;rport;branch=z9hG4bKPjfef2c145-ace0-44e2-9c7d-4dff06e43841
        From: "test" <sip:<number>@<my-IP>>;tag=8dbc786f-8138-404a-ae0e-5dbb76a9f421
        To: <sip:<number>@<voipms-server>>
        Contact: <sip:[email protected]<my-ip>:5060>
        Call-ID: <caller-ID string>
        CSeq: 27676 INVITE
        Allow: OPTIONS, REGISTER, SUBSCRIBE, NOTIFY, PUBLISH, INVITE, ACK, BYE, CANCEL, UPDATE, PRACK, MESSAGE, REFER
        Supported: 100rel, timer, replaces, norefersub
        Session-Expires: 1800
        Min-SE: 90
        Remote-Party-ID: "test" <sip:<number>@<IP>>;party=calling;privacy=off;screen=yes
        Max-Forwards: 70
        User-Agent: FPBX-15.0.16.49(16.9.0)
        Content-Type: application/sdp
        Content-Length:   239

        v=0
        o=- 178299335 178299335 IN IP4 <my-IP>
        s=Asterisk
        c=IN IP4 <my-IP>
        t=0 0
        m=audio 15588 RTP/AVP 0 101
        a=rtpmap:0 PCMU/8000
        a=rtpmap:101 telephone-event/8000
        a=fmtp:101 0-16
        a=ptime:20
        a=maxptime:150
        a=sendrecv

Thanks
cinergi

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.