Problem with UCP Daemon on FreePBX 7b distro


I’ve installed and configured freepbx 7 distro on a KVM but I am facing issues with the UCP Daemon - UCP Node is not running;

I’ve removed and installed UCP again but I find the following errors in the /var/www/html/admin/modules/ucpnode/node/logs/install.log:

gyp ERR! build error
gyp ERR! stack Error: `make` failed with exit code: 2
gyp ERR! stack     at ChildProcess.onExit (/usr/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:270:23)
gyp ERR! stack     at emitTwo (events.js:87:13)
gyp ERR! stack     at ChildProcess.emit (events.js:172:7)
gyp ERR! stack     at Process.ChildProcess._handle.onexit (internal/child_process.js:200:12)
gyp ERR! System Linux 3.10.0-327.28.2.el7.x86_64
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /var/www/html/admin/modules/ucpnode/node/node_modules/mariasql
gyp ERR! node -v v4.3.2
gyp ERR! node-gyp -v v3.0.3
gyp ERR! not ok
npm ERR! Linux 3.10.0-327.28.2.el7.x86_64
npm ERR! argv "/usr/bin/node" "/bin/npm" "update"
npm ERR! node v4.3.2
npm ERR! npm  v2.14.12

npm ERR! [email protected] install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] install script 'node-gyp rebuild'.
npm ERR! This is most likely a problem with the node-stringprep package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     node-gyp rebuild
npm ERR! You can get their info via:
npm ERR!     npm owner ls node-stringprep
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR!     /var/www/html/admin/modules/ucpnode/node/npm-debug.log

Also, I havethe same error repeated in /var/log/asterisk/ucp_err.log

Error: Cannot find module 'mariasql'
    at Function.Module._resolveFilename (module.js:325:15)
    at Function.Module._load (module.js:276:25)
    at Module.require (module.js:353:17)
    at require (internal/module.js:12:17)
    at Object.<anonymous> (/var/www/html/admin/modules/ucpnode/node/lib/freepbx.js:11:15)
    at Module._compile (module.js:409:26)
    at Object.Module._extensions..js (module.js:416:10)
    at Module.load (module.js:343:32)
    at Function.Module._load (module.js:300:12)
    at Module.require (module.js:353:17)
    throw err;

I’ve tried to install the mariasql module with the command:

npm install mariasql -g

but this has failed to solve the problem

Any ideas?

Thanks in advance for any assistance.

At the current time this is not working. The ucp node (not to be confused with UCP by itself. Which does work) version 13 does not work with cent 7

1 Like

Thanks for the prompt reply Andrew… should have posted before and saved myself a good few hours.

Always added knowledge though!