Problem with trunk registration

I have a Problem with my FreePBX trunk configuration. When I get an incoming INVITE, Asterisk sends out a 401 unauthorized. How can I Switch off trunk authorization???

You don’t want to do that, especially since you just announced you are going to. At least, not until you can provide a few more details.

There are ways to do this securely, but I doubt that anyone here is going to give you a detailed answer without at least knowing you are the person running that server.

It is a security risk but set

alwaysauthreject=no

in your SIP settings for the trunk and extensions, it should stop that basic SIP preamble.