Problem with ring groups not going to voicemail

Hi I have PBX Firmware: 1.813.210.58-1 and PBX Service Pack:

and have the following issue.

I have a ring group that used to go to a voicemail of one of my extensions when no one picked up.

What has been happening lately is that is give me a message “extension blabla(which happens to be the CID of the my line) can’t accept any messages because mailbox is full”

I have cleared out all mailboxes so i know that isn’t true.

What’s further more strange is if I set it to a different voicemail it works once or twice and then reverts back to the same problem.

Note when it does work it does not say extension “cid of my line” instead it says the extension number of the voicemail I am pointing it to.

I have tried deleting and recreating accounts involved. I have also tried using different accounts and always the fault is the same.

Please someone help.

Have you looked in your log files to see what error is being returned not just what your hearing but the possible reason?
Virtual or physical server?