Problem with remote extensions only when the power down


(Pablo) #1

How about gentlemen, let’s see if someone can help me with this that is driving me crazy. I have been using Freepbx with 3 remote extensions without problems for more than 5 years, well yes, with a problem that I do not finish solving.
I am using this version of Freepbx:
PBX version: 15.0.17.37 / PBX distro: 12.7.8-2104-1.sng7 / Asterisk version: 16.17.0

As I do not have a fixed IP, I use a FQDN, style to pay dyndns and it always works perfect for me, if I have a drop in the internet fiber connection, after a few minutes the IP is refreshed and the remote extensions reconnect without problems audio or anything like it, all perfect.

I use all configuration as SIP I do not want PSJIP, both in extensions and in trunks.

In ASTERISK SIP SETTINGS I have NAT = Yes / IP CONFIGURATION = DYNAMIC IP / DYNAMIC HOST = example.example.org (my fqdn like dyndns) / DYNAMIC REFRESH HOST = 60.

As I was saying, when the internet connection drops for some reason, which happens rarely because I have a good FTTH connection, in a few minutes the ip is refreshed and everything returns to normal in my remote extensions, which connect again and as if nothing would have happened.

The problem is here, when the electricity drops at home. When electricity recovers everything starts to work from scratch automatically, freepbx router and server, the ip is refreshed, the extensions connect normally remotely but from that moment on they do not there is audio in no remote extension, only in those that are within the LAN at home, those if they work well as well as the trunks.

The only way to get remote audio is to either restart the freepbx server or enter its interface and just click the “SAVE” button without even having changed anything, just to force an internal restart of asterisk , everything is working normally again and the audio begins to flow in the remote extensions.

I have tried when I have the problem to turn off the router and the only thing I get is that the IP of my FQDN is refreshed correctly but the audio problem persists in remote extensions, so I am forced to restart freepbx or press SAVE as If you had made any changes without having done it, all this to make it work again.

Any idea what can be wrong? An uncorrected bug?

Thanks. !!! and greetings from Spain. Paul


#2

Please paste a log of a failing call, including SIP trace.

At the Asterisk command prompt, type
sip set debug on
make the call, paste the Asterisk log for the call at pastebin.freepbx.org and post the link here.

Use the simplest failing case. For example, if *43 (echo test) fails to have audio, use that. If a call from a remote extension to a local extension fails, use that. Otherwise, use a call to an external number.


(Dave Burgess) #3

Also, since you’re using Chan-SIP instead of PJ-SIP, this is the expected result. These RTP failures were one of the reasons PJ-SIP was created.


(system) closed #4

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.