Problem with receive fax, FAXSTATUS=FAILED LICENSE EXCEEDED

Hi, i have a problem with recieve fax with asterisk. i’m using asterisk+freePBX with fax option. When i call to fax the fax rings. But when i send a fax I get the following message:

[Apr 13 15:29:41] VERBOSE[6852] logger.c: – Executing [[email protected]:1] NoOp(“SIP/1-pstn-00000007”, “Receiving Fax for: iaxFAX (900), From: “LOCAL PSTN CALL” <2-fax>”) in new stack
[Apr 13 15:29:41] VERBOSE[6852] logger.c: – Executing [[email protected]:2] Set(“SIP/1-pstn-00000007”, “FAX_RX_EMAIL=*@gmail.com”) in new stack
[Apr 13 15:29:41] VERBOSE[6852] logger.c: – Executing [[email protected]:3] Goto(“SIP/1-pstn-00000007”, “s,receivefax”) in new stack
[Apr 13 15:29:41] VERBOSE[6852] logger.c: – Goto (ext-fax,s,3)
[Apr 13 15:29:41] VERBOSE[6852] logger.c: – Executing [[email protected]:3] StopPlayTones(“SIP/1-pstn-00000007”, “”) in new stack
[Apr 13 15:29:41] VERBOSE[6852] logger.c: – Executing [[email protected]:4] ReceiveFAX(“SIP/1-pstn-00000007”, “/var/spool/asterisk/fax/1271165381.7.tif”) in new stack
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Channel ‘SIP/1-pstn-00000007’ receiving FAX ‘/var/spool/asterisk/fax/1271165381.7.tif’
[Apr 13 15:29:42] NOTICE[6852] res_fax.c: Negotiating T.38 for receive on SIP/1-pstn-00000007
[Apr 13 15:29:42] NOTICE[6852] channel.c: Dropping incompatible voice frame on SIP/1-pstn-00000007 of format ulaw since our native format has changed to 0x8 (alaw)
[Apr 13 15:29:42] WARNING[6852] res_fax.c: channel ‘SIP/1-pstn-00000007’ refused to negotiate T.38
[Apr 13 15:29:42] WARNING[6852] res_fax.c: Audio FAX not allowed on channel ‘SIP/1-pstn-00000007’ and T.38 negotiation failed; aborting.
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Executing [[email protected]:5] ExecIf(“SIP/1-pstn-00000007”, “1?Set(FAXSTATUS=FAILED LICENSE EXCEEDED)”) in new stack
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Executing [[email protected]:6] ExecIf(“SIP/1-pstn-00000007”, "0?Set(FAXSTATUS="FAILED FAXOPT: error: status: statusstr: “)”) in new stack
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Executing [[email protected]:7] Hangup(“SIP/1-pstn-00000007”, “”) in new stack
[Apr 13 15:29:42] VERBOSE[6852] logger.c: == Spawn extension (ext-fax, s, 7) exited non-zero on ‘SIP/1-pstn-00000007’
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Executing [[email protected]:1] GotoIf(“SIP/1-pstn-00000007”, “1?failed”) in new stack
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Goto (ext-fax,h,103)
[Apr 13 15:29:42] VERBOSE[6852] logger.c: – Executing [[email protected]:103] NoOp(“SIP/1-pstn-00000007”, “FAX FAILED LICENSE EXCEEDED for: *@gmail.com , From: “LOCAL PSTN CALL” <2-fax>”) in new stack

anyone can help me?

Sorry for my primitive english…

looks like you failed because of a failed negotiation with T38 and an inability to receive.

The license comment is an attempt to try and detect the failure reason because FFA does not do a good job of providing all failure modes. This time it may be a bad message but if you look at the output you can see that FFA is not giving other reasons thus it defaults to “License.”

hi,
after many tests I managed to reach fax. But not always … Sometimes works and sends it via email but sometimes give me the following error:

[Apr 14 12:45:39] VERBOSE [5722] logger.c: - Channel ‘SIP/1-pstn-00000027’ session FAX '2 ‘is complete, result:’ Failed ‘(FAX_FAILURE_PROTOCOL_ERROR), error: "NO_ERROR ‘, pages: 0, resolution:’ unknown ‘, transfer rate: ‘2400’, remoteSID:’’
[Apr 14 12:45:39] VERBOSE [5721] logger.c: - Executing [s @ ext-fax: 5] ExecIf (SIP/1-pstn-00000027 “,” 0? Set (FAXSTATUS LICENSE = FAILED exceeded) ") in new stack
[Apr 14 12:45:39] VERBOSE [5721] logger.c: - Executing [s @ ext-fax: 6] ExecIf (SIP/1-pstn-00000027 “,” 0? Set (FAXSTATUS = "FAILED FAXOPT error: NO_ERROR status: Failed statusstr: FAX_FAILURE_PROTOCOL_ERROR “)”) in new stack

The times that I received correctly get the following:

[Apr 14 12:57:39] VERBOSE [5856] logger.c: - Channel ‘SIP/1-pstn-00000028’ session FAX '3 ‘is complete, result:’ SUCCESS '(FAX_SUCCESS), error: "NO_ERROR ', pages 2, resolution: ‘204x196’ transfer rate: '14400 ‘, remoteSID:’ Fax '
[Apr 14 12:57:39] VERBOSE [5855] logger.c: - Executing [s @ ext-fax: 5] ExecIf (SIP/1-pstn-00000028 “,” 0? Set (FAXSTATUS LICENSE = FAILED exceeded) ") in new stack
[Apr 14 12:57:39] VERBOSE [5855] logger.c: - Executing [s @ ext-fax: 6] ExecIf (SIP/1-pstn-00000028 “,” 0? Set (FAXSTATUS = "FAILED FAXOPT error: NO_ERROR status: SUCCESS statusstr: FAX_SUCCESS “)”) in new stack
[Apr 14 12:57:39] VERBOSE [5855] logger.c: - Executing [s @ ext-fax: 7] Hangup (“SIP/1-pstn-00000028”, “”) in new stack

Someone understands it?

I’ve been testing sending faxes via the Internet. I’ve seen that works if the fax has attached a small file. But if nothing there is attached or are attached “a little” big file, it gives me error.

When I send without file give me an error:
FAX_FAILURE_TRAINING

edit:
I notice faxes that recieve have a rate transmition of 14400. But faxes that give error have a rate of 2400.
I accept all the rates in “fax configuration” in freepbx:

Fax Transport Options

Error Correction Mode: Yes
Maximum transfer rate: 14400
Minimum transfer rate: 2400

But not works…

[Apr 13 17:55:07] VERBOSE[9994] logger.c: – Channel ‘SIP/1-pstn-00000003’ FAX session ‘3’ is complete, result: ‘FAILED’ (FAX_FAILURE_PROTOCOL_ERROR), error: ‘NO_ERROR’, pages: 0, resolution: ‘unknown’, transfer rate: ‘2400’, remoteSID: ‘’
[Apr 14 12:23:18] VERBOSE[5540] logger.c: – Channel ‘SIP/1-pstn-00000026’ FAX session ‘1’ is complete, result: ‘SUCCESS’ (FAX_SUCCESS), error: ‘NO_ERROR’, pages: 2, resolution: ‘204x196’, transfer rate: ‘14400’, remoteSID: ‘Fax’